RAPIDMINER 9.7 BETA ANNOUNCEMENT

The beta program for the RapidMiner 9.7 release is now available. Lots of amazing new improvements including true version control!

CLICK HERE TO DOWNLOAD

Operator 'attribute' drop-down box not working in two operators

brwarnbrwarn Member Posts: 1 Contributor I
edited November 2018 in Help
I originally posted the message included below the dashed line.  I've discovered now that I'm getting the same error message noted below in the Data Transformation | 'Replace' operator as well.  So both the 'Replace Missing Values' and 'Replace' operator are behaving as described below.  This seems like a bug in the app to me.  Is there a way to address this issue?

I should note that I'm running version 5.3.015 on a MacBook Pro using OS X (Yosemite).

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I'm working through Matthew North's "Data Mining for the Masses" book.  An exercise early in the book walks the reader through the process of using the 'Replace Missing Values' operator to update some data in the Chapter03DataSet.csv file that's available at https://sites.google.com/site/dataminingforthemasses/.  I followed the steps exactly:
1. place in the Process window the 'Retrieve Chapter3' operator (verifying that it outputs the CSV's contents)
2. connect 'out' to 'exa' of the 'Replace Missing Values' operator
3. connect 'exa' to 'res',
4. set in 'Replace Missing Values' the attribute filter type to single, select the specified attribute, set default to 'value', and set replenishment value to 'N'.

No matter what I try, I get the following error message in a pop-up window: "No attribute selected.  Select an attribute by clicking on the 'attribute name' drop-down box."  

I've done all of this to the best of my knowledge so I don't know what I'm missing here.

Please suggest what I should check, etc. that I'm missing / overlooking.

Thanks,
Brian

Answers

  • CausalityvsCorrCausalityvsCorr Member Posts: 17 Contributor II
    Hi,

    have you solved this thing?

    Asking this, because I have same kind of problem with Apply Model with RM 5.3. All works perfect with modeling, but when integrating test data, then "no attribute selected".

    Regards P/K
  • mschmitzmschmitz Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 2,412  RM Data Scientist
    Hi,

    Rapidminer 5.X is not under development anymore. Have you tried version 6?


    ~Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
Sign In or Register to comment.