RapidAnalytics and R Extension with Red Hat Linux distribution

psp627psp627 Member Posts: 3 Contributor I
edited November 2018 in Help
I am having a problem with getting the R extension to work with RapidAnalytics Community Edition (latest version) installed on a red hat Linux distribution.
When I run a process that calls the R operator I get the following error:
Could not initiate session with native R. Try using server. Reason: Could not initialize R via JRI. Reason: Library wasn’t loaded.
I couldn’t find any documentation for installing on a Linux server but I used this site as a guide:
http://activeintelligence.org/blog/archive/install-r-extension-for-rapidminer-on-ubuntu-linux/
To troubleshoot this error we have confirmed that:
R is installed and working on the server
R extension is installed in the RM server plugins directory (This has been verified through the web interface- it is recognizing the extension)
The R packages rJava and JavaGD are installed in the R library These are installed in the only R library in the recognized R library path
The JAVA HOME and R HOME paths are set  I have tried a couple of variations on the R HOME path (pointing to the installation directory and directly to the libR.so)
Added the R HOME to PATH (/usr/lib64/R)
The rapidminer.r.native_lib path is set to  /usr/lib64/R/library/rJava/jri/libjri.so
Restarted RapidMiner server several times

So far none of this has worked. Since I can't find any instructions I am hoping someone in the community can help. Thanks.
Sign In or Register to comment.