Options

Selection of Attributes in Operators

AletyzAletyz Member Posts: 5 Contributor II
edited November 2018 in Help
When using an read excel operator or read csv operator the attribute names do NOT appear in any operator. Thus I have to type them in by hand, which slows my down a lot and is prone to errors. This problem occurs even though i have checked "read first rows as name"

Answers

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,993 RM Engineering
    Hi,

    you have three options:

    1) Import the data via "File" -> "Import Data" -> "Import CSV/Excel". You can then store the data in your repository and access it via a "Retrieve" operator. That way, the metadata is up to date right away.

    2) Add a breakpoint after the "Read CSV" operator and execute your process. When hitting the breakpoint, the metadata is up to date and can be used to edit subsequent operators. After that, save and hit continue.

    3) Similiar to 2), you can activate the "live metadata projection" in the top right corner just above the process by clicking on the paper clip icon. This costs a bit of performance but it results in the metadata being updated (and stored) after a process ran (even if it is aborted after the first operators). You could activate the feature, run your process until after the Read CSV operator and then stop it and edit the following operators.

    Regards,
    Marco
  • Options
    AletyzAletyz Member Posts: 5 Contributor II
    Installing the new version and selecting the paper clip solved the problem. Thank you very much!
Sign In or Register to comment.