🎉 🎉. RAPIDMINER 9.8 IS OUT!!! 🎉 🎉

RapidMiner 9.8 continues to innovate in data science collaboration, connectivity and governance

CLICK HERE TO DOWNLOAD

How to pass parameters to the W-BayesNet operator?

gladysCJgladysCJ Member Posts: 6 Contributor II
edited November 2018 in Help
Hi:

First, congratulations to all of you for creating the Rapid-I forum and specially for such an awesome program.

My problem is the following.  I'm trying to use the Weka classes for Bayes Nets in RapidMiner but I have some problems for getting the operator  W-BayesNet  to work as I need. The problem is that I  need to pass parameters  to the weka classes but so far I  have not been able to find the best way to do it. 

For instance, to implement the K2 algorithm, the Q parameter of W-BayesNet  is set to weka.classifiers.bayes.net.search.local.K2. But it is not enough because I need to pass some parameters to this Weka class, as for instance,  the parameter  P  (maximum number of parents), S (score), etc.  ( In Weka we use :  -Q weka.classifiers.bayes.net.search.local.K2 -- -P 3 -S BAYES) 

Any suggestions are very very welcome!!!

Thanks in advance,

Gladys

Answers

  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,750  RM Founder
    Hi Gladys,

    we will have a look into this and write back if we find out how this can be done...

    Cheers,
    Ingo
  • gladysCJgladysCJ Member Posts: 6 Contributor II
    Hi Ingo:
    Have you find a way to pass the parameters to the W-BayesNet class? The problem is that next week I will teach a graduate intensive course on Bayes Net for Data Mining and  I would like that the students could use RapidMiner instead Weka  for evaluating several learning algorithms for BNCs.
      Thank you for all your support.
      Cheers,
        Gladys
  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,750  RM Founder
    Hi Gladys,

    I have good news: I found the error. It was actually produced by a bug in Weka for the option handling for the BayesNet learner. It only worked correctly when -E option was also set. I fixed the bug in Weka and changed a setting in RapidMiner (which accidentally removed the -E option due to this Weka bug) and now everything works fine for me. I will send a bug report to the guys in Waikato so that they can fix the error for future versions.

    For now, you can access the fixed version (including a fixed Weka library) via CVS. Please refer to http://rapid-i.com/content/view/25/48/ for a description how this can be done. Of course this fix will also be part of the next release.

    Cheers and thanks for pointing this out,
    Ingo

Sign In or Register to comment.