Installing and running RM on protected machine

mikedkellymikedkelly Member Posts: 5 Contributor II
edited November 2018 in Help

I have a machine for which I have limited rights. I have run into the following issues installing and running RapidMiner

  • After installing the latest RM 64-bit Windows download, the application reports it is version 7.2.001 although Control Panel says is installed. The Marketplace thinks there is an update available, but when it is downloaded and installed, it still reports 7.2.001 is installed.
  • When I launch RM from the .exe I get the error "Java could not be launched. Probably there is not enough memory available. Please close all other applications and try again. Errorcode: 1." It launches fine from the batch file, but this is not a deployable workaround. I have tried launching the exe with administrator rights and get the same error. Prior to 7.2, RM would ask for the java path on first launch, but it no longer does this.

This may be related to not having full administrator rights to the PC. Most of our users will not even be able to run the exe as administrator. Can RM be configured to run without administrator rights?


Windows 8.1

Java 8

RM Windows 64-bit


  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,993 RM Engineering



    Let me start by stating that RapidMiner Studio does not require admin privileges to run, neither via .exe nor via .bat file. However you will not be able to update Studio from within the application itself if the update .exe does not get admin privileges.


    Having said that, let's see:

    • Likely caused by a corrupted installation directory. It sounds like you installed multiple versions into the same folder without it being properly cleared before. This usually happens when your Studio/lib folder contains .jar files from different versions (7.2.1 and 7.2.2 in your case). They are all loaded but the first one will win (7.2.1 in this case). So the installer writes down the correct version number into the registry but because you have duplicate files it will load the previous version .jar files.
    • This is odd. The error message really is not very descriptive, we are aware of that. Sadly logging what is actually happening is technically challenging when using the .exe file. Usually however when you experience this, the .bat will also fail. So the fact that this works but not the .exe is very curious indeed. They are meant to basically do exactly the same behind the scenes. If you fix the previous problem, does this one still persist or does it also go away?




  • Options
    mikedkellymikedkelly Member Posts: 5 Contributor II

    Thanks for the reply Marco:


    I performed a clean uninstall and reinstalled RapidMiner. I am still getting the same Java error when it tries to start from the shortcut. I tried RapidMiner 32-bit and 64-bit on both Windows 7 and Widows  8.1 and get the same issue. This started happening with Version 7.2 when the application stopped asking for the Jave.exe path on the first run. I have Oracle Java 8.0.51 b16 installed on these machines (64-bit). Is it possible that the shortcut tries to start the Java VM from the installed Oracle version whereas the batch file uses the jre that installs with RapidMiner?

  • Options
    femoshfemosh Member Posts: 1 Contributor I

    I am having similar problems running RMS on windows 10 64-bit. Has this problem been solved?

    It keeps giving java errorcode:1.

    I tried running the batch, that works but I could not update Text processing and AYLIEN and other extensions from marketplace.

    Any solution?

Sign In or Register to comment.