Options

[SOLVED] Unable to save to resultfile

a_molcanovasa_molcanovas Member Posts: 2 Contributor I
edited November 2018 in Help

 Hi, folks. Would anyone be able to tell me what I'm doing wrong? I was trying out PCA, which takes a while, so I wanted to save the results for later use, however, all the program does is create an empty file - the output does not get saved. I have attached screenshots of the output and my process, as well as the process XML.

 

Some (potentially) useful notes:

  • have tried deleting the result file and re-running the process.
  • I'm using RapidMiner Studio Free 7.2.003

Thank you for the help!

Best Answer

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Solution Accepted

    Hi,

     

    please add "Store" operators for each object you want to store for later use. The "resultfile" parameter is a) an expert parameter and b) a relict of the past.

    Storing data/objects for later use in RapidMiner is done via storing them in the repository, which is where the "Store" operator comes into play.

    Note that you can even save stuff to the repository if you forgot a "Store" operator and are only looking at the result itself. Right-clicking on the result tab will give you the option to store it in a repository.

     

    Regards,

    Marco

Answers

  • Options
    a_molcanovasa_molcanovas Member Posts: 2 Contributor I

    That did the trick - thanks a lot!

     

    If you're a moderator reading this thread feel free to close it. :)

Sign In or Register to comment.