R Extension Problem

MBMMBM Member Posts: 23 Contributor I
edited November 2018 in Help

Hey all, 

 

I want that little blue "R" in RapidMiner. I thought it wouldn't be so hard but it drives me crazy... 

What I have done so far:

- Installed R and the rJava package and data.table (note that the example "Execute R operators" do work)

- I have R_HOME, and JAVA_HOME

1.jpg

- in Systemvariablen>Path I put the following

 

2.jpg

 

But it doesn't work and I tryed several "tips" from different blogs and youtube videos but nothing worked. 

 

Can anybody help me please?!!!

 

Greetz

Marcel

 

 

 

Tagged:

Answers

  • Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,226   Unicorn

    This setup looks fine to me.  Presumably you have installed the "R Scripting" extension in RapidMiner and not the older "R extension" (which doesn't work with version 7 of RapidMiner).  What is the specific error message that you are receiving in RapidMiner when you try to execute a simple R script (ideally one that you have already tested in R so you know it works)?  If you can post a sample process it would be easier to troubleshoot.

     

     

     

    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
  • MBMMBM Member Posts: 23 Contributor I

    Correct, I installed R Scripting and I have RapidMiner Studio 7.2.003. I am very new to R so I now will find a short script to test with. I will post it later here. I don't know if this matters but the operator Execute R does work and as well the example processes. Just the "R" symbol is not in RM.

     

    Edit:

    I tryed this code in R and it worked

    library(ggmap)
    library(mapproj)
    map <- get_map(location = 'Europe', zoom = 4)
    ggmap(map)

    I pasted the code in RapidMiners "Execute R" but the following message came up:

     

    Exception: com.rapidminer.operator.OperatorException
    Message: Script terminated abnormally.
    Stack trace:

    com.rapidminer.operator.scripting.AbstractScriptRunner.run(AbstractScriptRunner.java:162)
    com.rapidminer.operator.scripting.AbstractScriptingLanguageOperator.doWork(AbstractScriptingLanguageOperator.java:90)
    com.rapidminer.operator.scripting.r.RScriptingOperator.doWork(RScriptingOperator.java:73)
    com.rapidminer.operator.Operator.execute(Operator.java:1002)
    com.rapidminer.operator.execution.SimpleUnitExecutor.execute(SimpleUnitExecutor.java:76)
    com.rapidminer.operator.ExecutionUnit$3.run(ExecutionUnit.java:811)
    com.rapidminer.operator.ExecutionUnit$3.run(ExecutionUnit.java:806)
    java.security.AccessController.doPrivileged(Native Method)
    com.rapidminer.operator.ExecutionUnit.execute(ExecutionUnit.java:806)
    com.rapidminer.operator.OperatorChain.doWork(OperatorChain.java:392)
    com.rapidminer.operator.Operator.execute(Operator.java:1002)
    com.rapidminer.Process.run(Process.java:1195)
    com.rapidminer.Process.run(Process.java:1091)
    com.rapidminer.Process.run(Process.java:1044)
    com.rapidminer.Process.run(Process.java:1039)
    com.rapidminer.Process.run(Process.java:1029)
    com.rapidminer.gui.ProcessThread.run(ProcessThread.java:65)

     Edit2:

    Correct me if I am wrong (I am totally new to R) I should use something like rm_main and {} and stuff, right?

     

    I tryed it with brackets and the message is the following without a map:

     

    Oct 29, 2016 9:15:21 PM INFO: No filename given for result file, using stdout for logging results!

    Oct 29, 2016 9:15:21 PM INFO: Loading initial data.

    Oct 29, 2016 9:15:21 PM INFO: Process starts

    Oct 29, 2016 9:15:22 PM INFO: Loading required package: ggplot2

    Oct 29, 2016 9:15:25 PM INFO: Loading required package: maps

    Oct 29, 2016 9:15:26 PM INFO: Map from URL : http://maps.googleapis.com/maps/api/staticmap?center=Europe&zoom=4&size=640x640&scale=2&maptype=terrain&language=en-EN&sensor=false

    Oct 29, 2016 9:15:27 PM INFO: Information from URL : http://maps.googleapis.com/maps/api/geocode/json?address=Europe&sensor=false

    Oct 29, 2016 9:15:30 PM INFO: Saving results.

    Oct 29, 2016 9:15:30 PM INFO: Process finished successfully after 8 s

Sign In or Register to comment.