The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Enabling R Scripting

carlcarl Member Posts: 30 Guru
edited November 2018 in Help

I'd like to try R scripting for the first time, but I'm struggling to get the R extension properly installed despite having read a number of posts on the topic.   I'm running macOS Sierra 10.12.1, and after completing the steps below, I get the message: path to Rscript front end seems to be incorrect.  But I can't see the problem in the path.  Can anyone please help?

 

 

Steps Completed

Installed R3.3.2

Installed Java Version 8 Update 112

Installed rJava and JavaGD via R

My Bash_Profile includes these lines

  • export R_HOME=/Library/Frameworks/R.framework/Versions/3.3/Resources/Library
  • export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/Home

RM preferences path to Rscript:  /Library/Frameworks/R.framework/Versions/3.3/Resources/library/rJava/jri/libjri.jnilib

Tagged:

Best Answer

Answers

  • Options
    carlcarl Member Posts: 30 Guru

    Thanks Thomas.  

     

    I entered:

    /Library/Frameworks/R.framework/Versions/3.3/Resources/Rscript

    into Preferences > R scripting, and will use the Execute R operator.

Sign In or Register to comment.