The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

Server Installation - standalone.sh does not initialize

OstrowskiOstrowski Member Posts: 2 Contributor I
edited November 2018 in Help

I am not an expert when it comes to SQL servers, specially using macOS, but I went through all steps from Server Installation Guide and getting help from a couple videos I finished all intalation steps.

 

16732037_707933352714286_1063188996_o.jpgConnection successfully established

 

However, when trying to execute the standalone.sh file I get the message bellow and no acces to localhost:8080. It might be something with the java path, but how to configure it?

 

Last login: Mon Feb 13 11:11:03 on ttys000

/Users/Ostrowski/Documents/bin/standalone.sh ; exit;

Ostrowskis-MacBook-Pro:~ Ostrowski$ /Users/Ostrowski/Documents/bin/standalone.sh ; exit;

=========================================================================

 

  JBoss Bootstrap Environment

 

  JBOSS_HOME: /Users/Ostrowski/Documents

 

  JAVA: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java/bin/java

 

  JAVA_OPTS:  -server -Xms1303m -Xmx6144M -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -XX:+UseG1GC -XX:MaxGCPauseMillis=50 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.modules.policy-permissions=true -Duser.country=US -Duser.language=en -Dcom.sun.jndi.ldap.connect.pool.timeout=300000

 

=========================================================================

 

/Users/Ostrowski/Documents/bin/standalone.sh: line 310: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java/bin/java: Not a directory

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

 

[Process completed]

 

 

Thanks for your time guys!

 

John Ostrowski

Tagged:

Best Answer

  • Options
    mmichelmmichel Employee, Member Posts: 129 RM Engineering
    Solution Accepted

    Hi John,

     

    you can specify the Java path (JAVA_HOME) in the standalone.conf files. If you are starting the server via standalone.sh you need to modify the standalone.conf file. In case of standalone.bat you need to edit the standalone.conf.bat file.

     

    Cheers,

    Marcel

Answers

  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    Ok, I'm not a MAC user but I'm sure there's a way to set your PATH environment variables. I have a JAVA_HOME path set to C:\Program Files\Java\jdk1.8.0_91\ and that does the trick for me.

     

    Another thing to check into, in Linux had to do a chmod +x ./standalone.sh in the past, it might also be a permission issue.

  • Options
    OstrowskiOstrowski Member Posts: 2 Contributor I

    Ok changing the path did the trick!

     

    It was apparently a bug that when getthing the path from java from System Preferences > Java > Java > View the Path already contained the final "/bin/java" which is applied by default on the standalone.sh. By removing the final extension the installation finished properly!

     

    Thank you RM Community!

     

    John Ostrowski

Sign In or Register to comment.