Options

RM 7.4

sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
edited November 2018 in Help

Hi...do I read that correct that RM 7.4 Server requires another complete re-install and not just an EAR upgrade?  We did this for RM 7.3...

Tagged:

Best Answer

  • Options
    JessForbesRMJessForbesRM RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 38 RM Data Scientist
    Solution Accepted

    Hey Scott,

     

    My colleague Jesús was a great help for this and forwarded along your installation folder.  I was able to execute with your installer.xml on linux and windows without errors when I added in my own file locations.  I think the big issue I noticed is that it looks like it is set to write to the exact same location as your 7.3 install.  

     

    This seems like the issue to me, the file architecture is very different between versions and likely the operating system isn't able to differentiate or locate the correct files.  Lets try changing your headless installation location to a seperate path and lets see how it goes.  

Answers

  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    Yes, you have to do a full upgrade. It's because of the parallelization framework that's been integrated into the guts. I know it's a PITA but think of the POWAH you get!

     

    Powah!.jpg

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    Thanks T-Bone.  Your Darth Vader inspiration allowed me to attempt this.  Unfortunately I got an installation error while trying to install on headless Linux:

     

    Feb 14, 2017 10:01:40 AM com.rapidminer.server.installer.install.Installer getInstallerRootDirectory

    INFO: Installation directory is: /opt/rapidminer-server-7-4/rapidminer-server-installer-7.4.0

    Installation started.

    20%

    40%

    60%

    80%

    Feb 14, 2017 10:01:43 AM com.rapidminer.server.installer.util.CommandLineHandler update

    SEVERE: An error occured! Installation failed!

    java.nio.file.NoSuchFileException: /opt/rapidminer-server-7-4/standalone/configuration/max-memory.conf

    at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)

    at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)

    at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)

    at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214)

    at java.nio.file.Files.newByteChannel(Files.java:361)

    at java.nio.file.Files.newByteChannel(Files.java:407)

    at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384)

    at java.nio.file.Files.newInputStream(Files.java:152)

    at com.rapidminer.server.installer.install.RapidMinerServerInstallerRunnable.configureMemorySettings(RapidMinerServerInstallerRunnable.java:792)

    at com.rapidminer.server.installer.install.RapidMinerServerInstallerRunnable.run(RapidMinerServerInstallerRunnable.java:119)

    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

    at java.lang.Thread.run(Thread.java:745)

     

    Thoughts?

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    Hi thanks for writing back.  No sorry I had changed the installation folder to a new one.  I guess i sent you a prior version of installer.xml.  Here's what I'm using (with some info XXX'ed out):

     

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
    <properties>
    <entry key="db_url">localhost</entry>
    <entry key="db_port">3306</entry>
    <entry key="server_service_id_overwrite">null</entry>
    <entry key="eula_accepted">true</entry>
    <entry key="server_port">8080</entry>
    <entry key="db_password">XXXXX</entry>
    <entry key="mail_password">MyMailPassword</entry>
    <entry key="installation_directory">/opt/rapidminer-server-7-4</entry>
    <entry key="license_key">XXXX</entry>
    <entry key="server_host">ip-10-0-1-137</entry>
    <entry key="db_driverclass">com.mysql.jdbc.Driver</entry>
    <entry key="server_register_as_service">true</entry>
    <entry key="mail_port">25</entry>
    <entry key="server_service_linux_variant">SUSE</entry>
    <entry key="mail_sender">rapidminer-server@example.com</entry>
    <entry key="memory_max">7000</entry>
    <entry key="db_system">MySQL</entry>
    <entry key="radoop_proxy_port">1081</entry>
    <entry key="mail_url">smtp.example.com</entry>
    <entry key="server_service_name">RapidMiner_Server</entry>
    <entry key="java_home">/usr/lib/jvm/java-8-oracle</entry>
    <entry key="db_user">XXXX</entry>
    <entry key="server_service_id">RMS250SVC</entry>
    <entry key="db_driver_path_is_relative">true</entry>
    <entry key="server_host_bind_only">false</entry>
    <entry key="radoop_proxy_enable">false</entry>
    <entry key="mail_user">admin</entry>
    <entry key="db_schema">rapidminer-server</entry>
    <entry key="db_driver_path">data/jdbc/mysql-connector-java-5.1.31.jar</entry>
    </properties>

    Thoughts?


    Scott

     

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    hmm ok downloaded the file fresh and then went through the same steps and this time it installed.  Weird.  OK thanks.


    Scott

     

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    ok now what's the magic trick to get my extensions to load?  I put them into the usual extensions folder (web mining and text mining), rebooted the server.  Nada.

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,520 RM Data Scientist

    is com.rapidanalytics.plugindir set correctly? What is the log saying?

     

    ~Martin

    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    yup that was the problem.  Arrgghh!

  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn

    Hi Scott,

     

    that's strange. It worked for me without problems. Perhaps disk full?

     

    Greetings, 

    Sebastian

Sign In or Register to comment.