I cannot connect to my database through RapidMiner Studio. I have installed the driver for MySQL

gcr84gcr84 Member Posts: 1 Contributor I
edited January 2020 in Help

I am having trouble connecting my database to RapidMiner. After pressing the 'Add Data' button in RapidMiner studio (upper left corner),

I choose the 'Database' option. After successfully choosing the data location (as well as testing the connection, which is ok),

I choose the table entitled 'events' (containing 5 attributes), and use the SQL Query:


FROM `events`

Then storing the data in Local repository -> Data (I tried processes as well), naming the data 'saninudge', pressing 'finish', I get an error pop-up window with the following message:

'Cannot read data set contents. Failed to read the data. No database selected'.

At this point I browsed the web and discovered that the MySQL Driver must be installed and configured. So I followed the steps and made sure everything has correct values in the setup. Afterwards, again atempting to connect the database, 

pressing the 'Add Data' button in RapidMiner studio (upper left corner), I choose the 'Database' option again. Again testing the connection to the correct database ('Saninudge') checks out, but then after pressing the 'Next' button the window is empty and no tables are visible. 

So at this point I am really stuck and could use some advice on how to successfully connect RapidMiner Studio to my database. Any ideas why the tables suddenly appears empty after installing the MySQL Driver? ANy help is much appreciated.

Best Answer

  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn
    Solution Accepted

    That sounds odd. Have you tried using the Read Database operator instead of "Add Data?"  That's the more manual and fine tuning way. 


    Also, if your DB table is huge, RM will want to fetch the metadata for it and it could take a LONG time. If that's the case, just go to Preferences and toggle off Fetch SQL Metadata.

Sign In or Register to comment.