Error executing background Job 'Loading Excel File': java.lang.ArrayIndexOutOfBoundsException: 1

m1mv2dot5m1mv2dot5 Member Posts: 1 Contributor I
edited November 2018 in Help

I am trying to load an Excel file fo rmy fianl project. I was able to load the Excel files 3/20/2017 just fine. Starting yesterday morning I began getting this error. I have tried using hte import wizard and the read.excel but, I still get this error. 

 

  • Exception: java.lang.ArrayIndexOutOfBoundsException
  • Message: 1
  • Stack trace:
  • com.rapidminer.operator.nio.model.xlsx.XlsxNumberFormats.setCellNumberFormatId(XlsxNumberFormats.java:65)
  • com.rapidminer.operator.nio.model.xlsx.XlsxNumberFormatParser.parseNumberFormats(XlsxNumberFormatParser.java:144)
  • com.rapidminer.operator.nio.model.xlsx.XlsxResultSet.(XlsxResultSet.java:216)
  • com.rapidminer.operator.nio.model.xlsx.XlsxResultSet.(XlsxResultSet.java:286)
  • com.rapidminer.operator.nio.model.xlsx.XlsxSheetTableModel.(XlsxSheetTableModel.java:94)
  • com.rapidminer.operator.nio.model.ExcelResultSetConfiguration.createExcelTableModel(ExcelResultSetConfiguration.java:175)
  • com.rapidminer.studio.io.data.internal.file.excel.ExcelSheetSelectionPanelModel$1.loadTableModel(ExcelSheetSelectionPanelModel.java:209)
  • com.rapidminer.studio.io.data.internal.file.excel.ExcelSheetSelectionPanelModel$1.run(ExcelSheetSelectionPanelModel.java:173)
  • com.rapidminer.gui.tools.ProgressThread$3.run(ProgressThread.java:550)
  • java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
  • java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
  • java.lang.Thread.run(Thread.java:745)
Tagged:

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    Did the file change in someway?

     

    Try using the "Add Data" button and see if it complains. There's usually an error panel that will tell you if there is a problem with the data itself.

Sign In or Register to comment.