ANNOUNCEMENT: RAPIDMINER 9.1 BETA HAS BEEN RELEASED TODAY!   PLEASE DOWNLOAD AND GIVE FEEDBACK. ENJOY AND HAPPY RAPIDMINING!   -- @sgenzer – Community Manager

I got an error during my rapid miner launch

ajay_varma1693ajay_varma1693 Member Posts: 1 Contributor I
edited November 9 in Help

It's showing " Java could not be launched. Probably there is not enough memory space. Please close all other applications and try again". But I have 8gb ram and nearly 1tb hard drive space. I don't why it's showing like that.

Tagged:

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,762   Unicorn

    Did you close all your applications? Windows sucks up 2GB right off the bat and if you're running other stuff that could compete with RM but usually 8GB is plenty. 

  • IngoRMIngoRM Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, RMResearcher, Member Posts: 1,406  RM Founder

    Potentially this might also have to do something with a mismatch between operating system and installed RapidMiner version.  Are you using Windows? Is it the 32 bit or 64 bit version?  And did you install the matching RapidMiner version for this?

     

    Hope this helps,

    Ingo

    Thomas_Ott
  • timematoomtimematoom Member Posts: 6 Contributor II

    I have the same problem, even when I restart my PC and just run rapidminer 64 bit on Windows 10, have 16 GB RAM.

     

    It worked fine just 10 days ago.

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,762   Unicorn

    Did you perform an upgrade?

     

  • timematoomtimematoom Member Posts: 6 Contributor II

    No, I don't. Everything is the same from 10 days ago (apart from updating Microsoft patch)

  • timematoomtimematoom Member Posts: 6 Contributor II

    Here is the report I got after running through Bat file

    https://pastebin.com/TKKe6kv3

  • JessForbesRMJessForbesRM Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 33  RM Data Scientist

    Hello @timematoom,

     

    Thank you for inluding the pastebin of the full error - the key part that I noticed is EXCEPTION_ACCESS_VIOLATION (0xc0000005) https://www.java.com/en/download/help/exception_access.xml

     

    This error can arise if you are not running the launcher with full permissions - can you launch it by right clicking run as administrator?

  • asmahassani08asmahassani08 Member Posts: 24 Contributor I

    hello, 

    I have worked with rapidminer for months but today I'm surprised by this error " Java could not be launched ".

    this is the problem messagermjava.JPG

     

    when I run rapidminerstudio.exe I got this error 

    RAPIDMINER_HOME environment variable is not set. Trying the directory 'C:\Progra
    m Files\RapidMiner\RapidMiner Studio'...
    Using local jre: C:\Program Files\RapidMiner\RapidMiner Studio\jre\bin\java.exe.
    ..
    Java Version: 1.8.0_141
    Launching RapidMiner Studio GUI now...
    Exception in thread "main" java.lang.Error: javax.xml.datatype.DatatypeConfigura
    tionException: Provider for class javax.xml.datatype.DatatypeFactory cannot be f
    ound
    at javax.xml.bind.DatatypeConverterImpl.<clinit>(DatatypeConverterImpl.j
    ava:892)
    at javax.xml.bind.DatatypeConverter.initConverter(DatatypeConverter.java
    :140)
    at javax.xml.bind.DatatypeConverter.parseBase64Binary(DatatypeConverter.
    java:341)
    at com.rapidminer.license.verification.JarVerifier.verify(JarVerifier.ja
    va:130)
    at com.rapidminer.launcher.GUILauncher.main(GUILauncher.java:283)
    Caused by: javax.xml.datatype.DatatypeConfigurationException: Provider for class
    javax.xml.datatype.DatatypeFactory cannot be found
    at javax.xml.datatype.FactoryFinder.findServiceProvider(FactoryFinder.ja
    va:304)
    at javax.xml.datatype.FactoryFinder.find(FactoryFinder.java:268)
    at javax.xml.datatype.DatatypeFactory.newInstance(DatatypeFactory.java:1
    45)
    at javax.xml.bind.DatatypeConverterImpl.<clinit>(DatatypeConverterImpl.j
    ava:890)
    ... 4 more
    Caused by: java.util.ServiceConfigurationError: javax.xml.datatype.DatatypeFacto
    ry: Provider org.apache.xerces.jaxp.datatype.DatatypeFactoryImpl not found
    at java.util.ServiceLoader.fail(ServiceLoader.java:239)
    at java.util.ServiceLoader.access$300(ServiceLoader.java:185)
    at java.util.ServiceLoader$LazyIterator.nextService(ServiceLoader.java:3
    72)
    at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:404)
    at java.util.ServiceLoader$1.next(ServiceLoader.java:480)
    at javax.xml.datatype.FactoryFinder$1.run(FactoryFinder.java:297)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.xml.datatype.FactoryFinder.findServiceProvider(FactoryFinder.ja
    va:292)
    ... 7 more

    I have windows 8.1 RAM 8GO. what's the problem source and how can I solved it. yesterday I have updated the radoop extension. after the installation of the extension is finished I haven't rerun the application. could this be a source ??

    thank you for your help.

Sign In or Register to comment.