Hive Test Connection Exception

HelloLolaHelloLola Member Posts: 18 Contributor I
edited November 2018 in Help

hello i am using rapidminer for my master degree (big data)

i want to use hadoop but i didn't get a connection using cloudera :(

please help me :(

[May 25, 2017 9:25:58 AM] SEVERE: java.util.concurrent.TimeoutException
[May 25, 2017 9:25:58 AM] SEVERE: Hive server 2 connection test timed out. Please check that the server/daemon runs and is accessible on the address and port you specified.
[May 25, 2017 9:25:58 AM] SEVERE: Test failed: Hive connection
[May 25, 2017 9:25:58 AM] SEVERE: Connection test for 'first connection' failed.

Tagged:

Answers

  • HelloLolaHelloLola Member Posts: 18 Contributor I

    hi i want to say i am using  Mac 2.66 GHz intel core i7 and 8Go 1067 MHz DDR3 :(

    thank you in advance

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    First off, this is in the wrong thread. I will move this the Radoop Forum.

     

    Are you using the Cloudera Quickstart image? Did you follow these configuration instructions? https://docs.rapidminer.com/radoop/installation/distribution-notes.html

    phellinger
  • HelloLolaHelloLola Member Posts: 18 Contributor I

    hello thank you for replying :)

    yes i did all the steps but it still not working

    can you help me please

     

  • HelloLolaHelloLola Member Posts: 18 Contributor I

    yes i am using Cloudera Quickstart image and these are some screenshot that describe my situation

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    Untoggle the default ports settings and try that.

     

    If you visit the Cloudera manager, is Hive running?

  • HelloLolaHelloLola Member Posts: 18 Contributor I

    yes, when I untoggle it it doesn't work, and all of the cluters have a bad status (red color). When I correct some error an another error appear :( also the cloudera sevice slows the mac :(

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761   Unicorn

    If the Hive status is red (bad), then you have something going on with your cluster. Make sure Hive is green before you try to connect Radoop to it. 

  • HelloLolaHelloLola Member Posts: 18 Contributor I

     

     

    Hello, I was trying to correct the error in cloudera and having the green point, but I still have the same problem :( :(

    Please help me, I can't find a solution for this :(

    thank you in advance

     

     

     

     

    Capture d’écran 2017-07-05 à 00.44.36.png

  • HelloLolaHelloLola Member Posts: 18 Contributor I

    This is the configuration I made :(

    please help me :( How can I solve this problem?

     

     

     

    Capture d’écran 2017-07-05 à 00.35.56.pngCapture d’écran 2017-07-05 à 00.28.12.png

  • phellingerphellinger Employee, Member Posts: 87   RM Engineering

    Hi,

     

    1) The "too many parallel JDBC connections are held" is an error that may appear after several unsuccessful connection attempts. It is not the original cause of the problem, but when it appears, you need to restart Studio, unfortunately, we hope to fix this very soon.

     

    2) I guess the original problem is still the Hive connection timeout. First of all, I would increase the timeout values for the connection testing, as the quickstart VM that runs on the same machine may be slow. In Preferences, you can filter for "timeout", and increase these two Radoop settings, see the screenshot:

    timeout.png

     

    3) Check if quickstart.cloudera address can be accessed from the host machine, for example using ping or a web browser to access the Cloudera Manager (not from the guest, but the host machine).

     

    4) You can check if the Hive connection request reaches the Hive service by checking the Hive service's Log on the Cloudera Manager interface (called Role Log). If you see log entries when RapidMiner runs the Hive connection test, then the request reaches the cluster, otherwise there may be a networking problem.

     

    5) If you are using this cluster for RapidMiner (Radoop) only, you can safely remove several services that are not used by the RapidMiner. You can make the cluster much faster with that. To achieve that, you can Stop and Delete all services except HDFS, Hive, Spark, YARN (MR Included), ZooKeeper - these are needed by RapidMiner.

     

     

    Best,

    Peter

Sign In or Register to comment.