Getting "Attribute filter does not match an attribute" and similar messages...

RMBPRMBP Member Posts: 4 Contributor I
edited December 2018 in Help



On filter, discretize, and sort operators, I am getting the message that my attribute (usually when I select the confidence attribute of the model the data has previously run through) is not there. Some of the time the operator still operates properly, others do not "operate" at all and just pass data through.


I have turned on the "Synchronize Meta Data with Real Data". Any tips on this?


Example chain: Cross Validation, Select Attributes, Sort (sometimes get message), Discretize (does not discretize at all).


Best Answer

  • Options
    Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,635 Unicorn
    Solution Accepted

    Yes, if you are trying to operate on attributes with a special role, you will need to check the box that says "include special attributes" and that will allow the operator to affect those (assuming they also meet whatever filtering criteria you are using).


    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts


  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    hello @RMBP - hmm that's rather odd.  Sometimes metadata does not propagate for a variety of reasons but I think I'd like to see your process (use the </> button to paste into message) and your data if you are able to post.



  • Options
    RMBPRMBP Member Posts: 4 Contributor I



    What I am noticing is it may have to do with confidence being a special attribute, when a 'set role' to switch it to a regular variable or generate a new attribute that is a copy of the confidence, it works fine.


    A similiar element I'm seeing is the filter operator has issues filtering by row number, it says that row 1 is a higher number than the highest row... although the filter actually works fine.

Sign In or Register to comment.