Cannot use any other data to run workflow from Rapid Miner Book

Andreas_LorenzAndreas_Lorenz Member Posts: 2 Contributor I
edited November 2018 in Help

I would like to use the Similarity-based Content Recommendation process from the rapid miner book (http://rapidminerbook.com/index.php/chapter-downloads/chapter-9/, chapter 9.5.2.). It works fine with the provided .ioo, .md and .properties data, but when I load my own data (attributes are the same) into the repository, it doesn’t work although there is no error message.

 

I already convertet the original .ioo file into a new excel file (with the write excel operator) and added this excel file to the repository, which is also not working. I presume I am missing something while adding an excel file to the repository (I start with +add data and follow the import wizard). Does someone know where the problem could be? 

 

Thank you for your hints and help. 

 

 

 

Tagged:

Answers

  • Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn

    The first step I would look at is why you can't seem to load your data. Try converting your XLSX file to a CSV and use the Read CSV operator. Sometimes in XLSX files there are wierd formating or encoding that can mess things up. 

  • Andreas_LorenzAndreas_Lorenz Member Posts: 2 Contributor I

    Thank you for your reply. Unfortunately the import with CSV made things worse. But I tried the excel import with two different processes and it worked, so I conclued that the excel import must be ok. I searched for solutions within the process and was successful. I added two "nominal to text" operators after the first item preprocessing operator. 

     

     

    sgenzer
Sign In or Register to comment.