"OutofMemory error; Changing MAX_JAVA_MEMORY in RapidMinerGUI.bat didn't help :-("

ruserruser Member Posts: 40 Maven
edited May 2019 in Help
When I was running the Rapidminer process, it got interrupted with a Dialog box giving the following error:
  Process failed
  OutofMemoryError caught
  Java Heap space

Hence, I tried increasing the memory by changing MAX_JAVA_MEMORY to a higher value, in the RapidMinerGUI.bat file (because, I use the GUI version started from the Windows 'Start' menu). But, it has no effect on the process, and the same error is repeated. Should I change it somewhere else?

Please clarify!


  • Options
    landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,531 Unicorn
    Please take a look at the memory monitor if the available memory has been increased.

    Some operations do need a very huge amount of memory if used on too big datasets. For example a PCA will use a mxm Matrix with m beeing the number of attributes. If your dataset has 30.000 attributes, it will try to create a matrix with 30.000x30.000 entries. This roughly would need 7 GBs of RAM...

  • Options
    ruserruser Member Posts: 40 Maven
    Ok. But, am I changing the memory limit in the right place?
    I changed it RapidMinerGUI.bat and then restarted. I even tried changing it in rapidminer.bat. But, it didn't help. The memory usage still shows the old memory consumption value only, before the OutofMemory error is thrown. This is the reason why I thought that my changes did not have any impact.
    Should I change it anywhere else?
  • Options
    cherokeecherokee Member Posts: 82 Maven
    Hi ruser,

    I think you changed it in the right place but are not running the right program. Your start menu entry is probably not linked with RapidMinerGUI.bat. Try running this .bat-file directly.

    Best regards,
  • Options
    ruserruser Member Posts: 40 Maven
    No. After changing the MAX_JAVA_MEMORY, I executed the .bat file only. But, the command window opens and closes immediately, and the GUI window does not open at all. I even tried setting 'echo on' at the start of the .bat file. But, there is no change in the behaviour, except that the command window abruptly (not possible to notice) showing some echoed statements and closing immediately.

    And, I checked where the shortcut for Rapidminer in the 'Start' menu points to. It refers to at "D:\Program Files\Rapid-I\RapidMiner\RapidMiner.exe". In that case, where do I change the Memory size?
  • Options
    cherokeecherokee Member Posts: 82 Maven
    I'm sorry, but I don't know where to change the memory for the .exe. But for the .bat file you can try to open the command promt and execute it from there. Then you will see the echoed statements.

    By the way. I am running the batch file and changed there MAX_JAVA_MEMORY. But I don't remenber the necessary steps  :(
Sign In or Register to comment.