Port Configuration for RM Server on AWS

JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
edited November 2019 in Help

Hi guys,


I'm having a few problems configuring ports for AWS with RapidMiner Server 7.6.1.  It runs fine on my local machine, but on EC2 (with either Windows or RHEL) the server does not seem to be accessible. 


Windows I'm more familiar with so here is what I have done.

My configuration at the moment is set very open. 

- Windows Server: No firewall. 

- AWS Security: Allow all ports from All locations.

- RapidMiner Port: 8080


Currently on the Windows machine I also have a Tomcat web server running using port 8081 & this is accessible remotely (weirdly not when logged in using localhost)


Can anyone share any gotchas that I've missed?  As from what I understand anyone and their dog should be able to reach it. 

(Once pointed in the right direction I'll be securing it further).


(Please note that I can't access the RM Server AWS AMI from here so if you would be willing to share any port configurations that are on it then please let me know.)






Best Answers

  • Options
    Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,635 Unicorn
    Solution Accepted

    Hi @JEdward, AWS can definitely provide challenges with all its different security layers :smileyhappy:. 

    I've set up RapidMiner Server 7.6.1 on AWS Windows machines so it is definitely workable.  Here are a few settings you might double-check:

    • ensure that there isn't anything blocking port 8080 on AWS at the ACL or the VPC level that is conflicting with the security group setting
    • add 1081 and 80 as accessible inbound ports as well (not entirely sure why these are needed, but they are part of the RapidMiner Server AMI pre-configured security group)
    • make sure all outbound TCP traffic is allowed via the security group
    • make sure that the VPC is also set to allow public IP access via DNS resolution  
    • try turning off  “IE Enhanced Security Configuration” on the Windows Server (I'm not entirely sure how this works on the back end but it appears to do some kind of port blocking)
    • definitely turn off the Windows Firewall entirely (don't just set rules for allowing traffic)

    I hope one of these does the trick!  Let me know what you find.


    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn
    Solution Accepted

    Hi @Telcontar120


    Thanks for the pointers, weirdly all the settings I had were open. 

    However, you did inspire me to test out if it would run on 8081 (as that is the port that the other webserver is running on successfully).  And yes, success! 


    It seems to be that certain AWS configurations are blocking port 80 & 8080 by default without there being any obvious block in the security or VPC settings.  Solution, my RM is now on 8082. 



Sign In or Register to comment.