Rapidminer displays certain times wrong after Excel import

felix_wfelix_w Member Posts: 61 Contributor II
edited November 2018 in Help

Dear Rapidminer Community, 


it's me again, yet with another problem ;) 


This time I am importing data from an Excel into Rapidminer which contains dates in the format dd/mm/yyyy hh:mm. Most of the imports are correct but the software makes one mistake which is crucial for me.


Lets say I have a time in my excel: 23.10.2017 00:00 (which is for me midnight), Rapidminer imports this time stamp as: 23.10.2017 12:00AM. Shouldn't it rather be 12:00PM or 00:00AM? I am not a US citizen but I think 12:00 AM is definitely wrong if I want to have the midnight time, right?


How can I fix this problem? With a "date to nominal" operator and than somehow convert it again?


Best Answer

  • Options
    BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955 Unicorn
    Solution Accepted



    This is just an artefact of the time format used by RapidMiner. 

    12:00:00 AM is actually 00:00:00 in 24 hour format. You can easily check this by using Date to Nominal. Your timestamps are correct, they are just displayed in an unusual (to you and me) way. 


    I would also prefer if RapidMiner used the ISO time format (yyyy-MM-dd HH:mm:ss) for display.





  • Options
    felix_wfelix_w Member Posts: 61 Contributor II

    Hi Balazs, 


    thank you for your fast reply! Ok, this looks really odd to me but at least I can save some time reformating my table ;) 




Sign In or Register to comment.