Issue with Importing process

jov_slavicajov_slavica Member Posts: 3 Contributor I
edited December 2018 in Help

Dear RM community members,


I am a student and have started using RM last week. We have had several classes so far and now I want to import some processess made by our professor to analyze, so as to be able to complete a class project. However, for me this is rather not possible by going to File and choosing Import process. Althought RM enables the import of the chosen file, and one can see it is computing something in the lower right corner, however, there is nothing in my Repository as the result. As I have seen at some point on the progress line the inscription Recommendations update, it occured me to update and install everything I was able to.

But Import Process still does not work.


Sometimes simple copy/paste onto the desired repository folder is possible (and the system presents an floppy disc icon, asking if I want to store the copied process there). However, this is rather more impossible than it is possible. To summarize, I have managed to copy 8 processess in total into the repository so far, and I have been doing this for 6 hours now.


Can somebody help me, please?

PS - I am not the only one who is having this issue - my classmate with whom I am doing a class project is having this it too!

Many thanks a lot for troubleshooting and help!



  • Options
    atimmatimm Employee, Member Posts: 24 RM Engineering

    Hi @jov_slavica,


    if you would like to import several processes that you got as files into a local repository, you can

    1. Right-click on the target repository and select "Configure Repository".
    2. Copy the root directory path and open it in your file browser.
    3. Paste the process XML files into this directory or into a subdirectory.
    4. Refresh your local repository.

    Hope this helps.

  • Options
    jov_slavicajov_slavica Member Posts: 3 Contributor I

    Hi, @atimm


    thank you for fast reply.

    As for your proposed solution - I had to import .rmp files, not the XML ones. 


    I managed to import processes last night, but the solution was pretty much trivial. And it did not work to my friend when she tried, so it is still not a universal solution applicable for all with the same issue.


    I did the `Import process` first, which is executing but with no result in my case, and then copy and paste the same desired process onto the desired repository subfolder. This worked every time with all the processes I had put inside, say some 20.







  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    not a RM 8 Release Issue - moving to Getting Started.





  • Options
    Edin_KlapicEdin_Klapic Moderator, Employee, RMResearcher, Member Posts: 299 RM Data Scientist

    Hi @jov_slavica,


    since the Repository is stored within your user home (the path would be something like C:\Users\<user_name>\.RapidMiner\repositories\Local Repository\<subfolder>) you can also copy the .rmp files there.

    When you refresh the Local Repository from within RapidMiner Studio the process should be available.


    Best regards,


  • Options
    jov_slavicajov_slavica Member Posts: 3 Contributor I

    Dear @Edin_Klapic,


    many thanks for this useful tip!

    It's a permanent solution to the problem!


    Best regards,


  • Options
    AndrianaAndriana Member Posts: 1 Newbie
    I'm a student, and started to learn RapidMiner on course in university. 
    The teacher gave the task to import Excel file. I did it. But when I add this file to Process, I have been had a problem. What I need to do to fix it?
  • Options
    BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955 Unicorn

    What did you do exactly? Importing an Excel file can be done in two ways:

    1. With the Import wizard. The result, a table, will be available in the repository. It seems that you did this, or at least attempted it. 
    The message you see is just a warning. The operator is probably fine. But to see or use the data, you should connect the output port of this operator (the half-circle on the right side) to the process output. That's not visible in your screenshot.

    2. Using the Read Excel operator which also has a wizard.

    There are videos in the Academy about this: https://academy.rapidminer.com/catalog?query=import excel

    Best regards,

Sign In or Register to comment.