The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

rm 8 server com.rapidanalytics.plugindir doesn't refer to default agent

RayJhongRayJhong RapidMiner Certified Analyst, Member Posts: 11 Contributor II
edited November 2018 in Help

Hi There,

 

As i known that rm 8.0 server could implement distrubuted environment by assigning job agents accross instances. And there is also an agent to operate default queue named "agent-bundled" if you don't assign tasks to other job agents.

However, recently, i tried to install extensions for RM server following this instruction, after restart RM server, i found new extensions appear on web UI which is great. (Operator Toolbox & Text Processing)

Screen Shot 2018-02-02 at 6.14.10 PM.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

But when i execute process on server using default queue, got an error said can't find "SMOTE UPSAMPLE" operator which is from "Operator Toolbox".

I have to manually put those extension into C:\RapidMinerServer\job-agent\extensions to be able to load those extensions when running default queue, seems like default queue won't refer to this parameter "com.rapidanalytics.plugindir" in system settings as below:

Screen Shot 2018-02-02 at 6.26.46 PM.png

 What can i do if i want default job agent to take "com.rapidanalytics.plugdir" this parameter, otherwise i have to do it twice when adding new extensions?

 

Any suggestion would be appreciated.

 

Sincerely,

Ray Jhong

 

Tagged:

Best Answer

  • Options
    Edin_KlapicEdin_Klapic Moderator, Employee, RMResearcher, Member Posts: 299 RM Data Scientist
    Solution Accepted

    Hi @RayJhong,

     

    You can set the parameter

    jobagent.container.extensionsDir = <path-to-your-RapidMiner-Server-extensions-folder>

    in the .../job-agent/config/config.properties file.

     

    This should solve the issue. We are aware of this and put it on our list.

     

    Best regards,

    Edin

Sign In or Register to comment.