Not more than 200 lines

dixidixi Member Posts: 3 Contributor I
edited November 2018 in Help
Hello everybody,

i'm new to RM but after a closer look i think it is very well. At this moment i play with RM to learn more about it.
My first project was a quiet easy one a market basket analysis with association rules. For this analysis i got a data file with
the following format:

1st row: milk,butter,bread,...
2nd row:0,1,0,...
3rd row: 1,0,0,...

The file got 800 rows but RM reads only 200 lines. I import the file with "Example source"-operator and use "Start data loading wizard".
Overall it works and i get some association rules, but i think only for 200 rows of my data.

Thanx for help.
Dixi

Answers

  • landland RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 2,525   Unicorn
    Hi Dixi,
    there then is an error in your file. In the log window there should be a message. Take a look and note the line number. Check this line in an editor to correct the data.
    Otherwise you could use the "skip_error_lines" parameter in the example source operator to ignore such lines.

    Greetings,
      Sebastian
  • dixidixi Member Posts: 3 Contributor I
    Hello Sebastian,

    thanks for your advice. Certainly i checked my file around line 200 but there's still no error. This means that there aren't any blank cells or non-binary values or anything else. The data file is absolutely clean. I'll try to use the "skip_error_lines" parameter and tell you the conclusion. Maybe i'll discover what's going wrong with my data file.

    Kind regards
    Dixi
  • dixidixi Member Posts: 3 Contributor I
    Hello again,
    I think my data is clean. When i loaded my data, RM tells me no errors. Just at the little preview it shows me only 200 lines but in fact RM imports all 800+ rows. Thus my association rules are right.

    Thanx anyway for help.
    Dixi
Sign In or Register to comment.