Options

How to Import Data with Date Column YYYY-MM-DD (ISO 8601)

thomas_wiedmannthomas_wiedmann Member Posts: 60 Guru
edited December 2018 in Help

I try to Import some CSV Data into RapidMiner including some date column. I get ISO 8601 Date format YYYY-MM-DD.

https://en.wikipedia.org/wiki/ISO_8601

 

Now I will change imported data type from polynominal to date. I just get errors like.

 

1. Import RAW Data - polynominal

RapidMiner2.JPG

 

 

2. Change type to date looks like this "red error monster"

RapidMiner3.JPG

 

Data

EINGANG
2010-06-07
2011-03-02
2013-03-08
2015-03-02
2017-03-10
2011-01-03
2013-01-02
2015-02-02
2016-12-22
2011-08-09
2013-07-31
2015-07-27

How can I change this ISO_8601 Date standard format to rapidminer date?

 

Thanks!

Thomas

 

Tagged:

Best Answers

  • Options
    David_ADavid_A Administrator, Moderator, Employee, RMResearcher, Member Posts: 297 RM Research
    Solution Accepted

    It seems that the import wizard can only handle date that match exactly the predefined formats in the drop-down menu.

    In your case you only habe yyyy-MM-dd and not yyyy-MM-dd HH:mm:ss .

     

    In this case, just use the Nominal to Date Operator and specify yyyy-MM-dd as date format.

     

    Best,
    David

  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    Solution Accepted

    Hi,

     

    I cannot reproduce the problem. You can enter "yyyy-MM-dd" in the Date Format field and then it'll work. You need to press "Enter" after changing the date format field or click somewhere outside of the date format textfield for manual changes to take effect, but that's about it.

     

    Regards,

    Marco

     

    works.png

     

     

     

Answers

  • Options
    thomas_wiedmannthomas_wiedmann Member Posts: 60 Guru

    Ok, but RapidMiner (Nominal to Date Operator) has to transform this column every time I execute the process. It's not the best solution.

    Hope next version will fix that.

     

    Thanks

    Thomas

  • Options
    thomas_wiedmannthomas_wiedmann Member Posts: 60 Guru

    Thanks, that's it. I try it several times to change this import format, with no effect. But now it works.

     

    Thanks, my fault..
    Thomas

Sign In or Register to comment.