The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.
Options

upload greek in mysql database

icsd11159icsd11159 Member Posts: 16 Maven
edited January 2020 in Help

Hello,

I have a connection with MySQL database and i pass values in a table but i have greek words and in database tha results are like: ??????dbn.PNG

Tagged:

Best Answer

  • Options
    icsd11159icsd11159 Member Posts: 16 Maven
    Solution Accepted

    Thank you all for your help , i just solve my problem by setting the appropriate connection properties in RapidMiner Studio : via Connections > Manage Database Connections > Advanced and check the 

    <SPAN class="str">characterEncoding</SPAN>

    and write utf8 in the blank next to it .

     Also must check and  

    <SPAN class="str">useEncoding</SPAN>

     

Answers

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    hello @icsd11159 - is that a RapidMiner screenshot? I do not recognize those icons.


    Scott

     

     

  • Options
    icsd11159icsd11159 Member Posts: 16 Maven

    This is a screenshot from my database , that writes greek perfect from hltm/php but when i use 'write database' operation they turn into ?????.I use 'execute SQL' with 'SET CHARACTER SET UTF8' but nothing is change .Do you have any idea to fix this ?

  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn

    Is your RapidMiner display set to Unicode? 

     

     

     

     

     

  • Options
    icsd11159icsd11159 Member Posts: 16 Maven

    My results are in greek , if that's what you asking

    exampleset.PNG

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    ah ok that makes more sense. Most likely that's an encoding issue. Can you check and see if your system RapidMiner encoding is the same as your database? I can see if your system is ISO-8859-1 and your database is UTF-8, you would have a problem.


    Scott

     

    Screen Shot 2018-04-10 at 9.35.50 AM.png

  • Options
    JEdwardJEdward RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 578 Unicorn

    Thanks, was just checking by eliminating the first possibility. 

    The issue might actually the first one I suspected, the JDBC driver could need an additional connection parameter set as advanced parameters. 

     

    Set useUnicode to yes & characterEncoding to UTF-8

    This should resolve it.

    <SPAN class="pln">jdbc</SPAN><SPAN class="pun">:</SPAN><SPAN class="pln">mysql</SPAN><SPAN class="pun">://</SPAN><SPAN class="pln">localhost</SPAN><SPAN class="pun">:</SPAN><SPAN class="lit">3306</SPAN><SPAN class="pun">/</SPAN><SPAN class="pln">db_name</SPAN><SPAN class="pun">?</SPAN><SPAN class="pln">useUnicode</SPAN><SPAN class="pun">=</SPAN><SPAN class="pln">yes</SPAN><SPAN class="pun">&</SPAN><SPAN class="pln">characterEncoding</SPAN><SPAN class="pun">=</SPAN><SPAN class="pln">UTF-8</SPAN>

     

    See here: https://stackoverflow.com/questions/5090303/how-do-i-get-greek-characters-in-my-database-using-jsp

     

     

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager

    oh nice catch, @JEdward.

     

    Scott

     

  • Options
    icsd11159icsd11159 Member Posts: 16 Maven

    Thank you for your reply!

    I agree with you and i think that this must be the solution . But when i change the url path it gives me error dtbe.PNG

    My ManageDatabaseDrivers is like :

    mdd.PNG

Sign In or Register to comment.