Split Concat data into columns

asn4293asn4293 Member Posts: 24 Contributor I
edited January 2020 in Help

Dear @IngoRM 

It is second time I am really disappointed with another operator.  See here I splitted my concat data into separate rows it should separate into more than three columns but it only separate into three columns which makes rest of the data left out. I don't know how to overcome this problem please hep me.

Thank you,https://drive.google.com/open?id=1XvGZKqBWT1LDV0kFWDOKecGUbvxDpcWK


<?xml version="1.0" encoding="UTF-8"?><process version="8.0.001">
<operator activated="true" class="process" compatibility="8.0.001" expanded="true" name="Process">
<process expanded="true">
<operator activated="true" class="read_excel" compatibility="8.0.001" expanded="true" height="68" name="Read Excel" width="90" x="112" y="187">
<parameter key="excel_file" value="C:\Users\shahida1\Desktop\language.xlsx"/>
<parameter key="imported_cell_range" value="A1:B14065"/>
<parameter key="first_row_as_names" value="false"/>
<list key="annotations">
<parameter key="0" value="Name"/>
<list key="data_set_meta_data_information">
<parameter key="0" value="User Sys ID.true.integer.id"/>
<parameter key="1" value="Language.true.polynominal.attribute"/>
<operator activated="true" class="split" compatibility="8.0.001" expanded="true" height="82" name="Split" width="90" x="246" y="289">
<parameter key="attribute_filter_type" value="single"/>
<parameter key="attribute" value="Language"/>
<parameter key="attributes" value="Language"/>
<parameter key="split_pattern" value="[-!&quot;#$%&amp;'()*+,./:;&lt;=&gt;?@\[\\\]_`{|}~]"/&gt;
<operator activated="true" class="multiply" compatibility="8.0.001" expanded="true" height="103" name="Multiply" width="90" x="380" y="289"/>
<operator activated="true" class="select_attributes" compatibility="8.0.001" expanded="true" height="82" name="Select Attributes" width="90" x="447" y="136">
<parameter key="attribute_filter_type" value="subset"/>
<parameter key="attributes" value="Language_1|Language_2|Language_3"/>
<connect from_op="Read Excel" from_port="output" to_op="Split" to_port="example set input"/>
<connect from_op="Split" from_port="example set output" to_op="Multiply" to_port="input"/>
<connect from_op="Multiply" from_port="output 1" to_op="Select Attributes" to_port="example set input"/>
<connect from_op="Multiply" from_port="output 2" to_port="result 2"/>
<connect from_op="Select Attributes" from_port="example set output" to_port="result 1"/>
<portSpacing port="source_input 1" spacing="0"/>
<portSpacing port="sink_result 1" spacing="0"/>
<portSpacing port="sink_result 2" spacing="0"/>
<portSpacing port="sink_result 3" spacing="0"/>



Best Answer

  • Options
    Thomas_OttThomas_Ott RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,761 Unicorn
    Solution Accepted

    @asn4293 your process works for me, but I suspect the full meta data is not propogating. Just toggle on Synchronize Metadata with Real Data on the Process pull down menu and run your process again. 


  • Options
    asn4293asn4293 Member Posts: 24 Contributor I


    You helped me again thank you so very much you are expert in Rapidminer 

Sign In or Register to comment.