Rapidminer slows down when connected

AndaloussiAndaloussi RapidMiner Certified Analyst, Member Posts: 3 Contributor I
edited December 2018 in Help

Rapidminer slows down when connected: It seems like I am automatically connected to the RM cloud when I connect to the net... that's why it slows down. Is there any parameters setting which allows me to work locally on my desktop? (although I am connected to the net and without the software automatically connecting to the cloud)

Tagged:

Best Answer

  • Knut-RMKnut-RM Posts: 108  Administrator
    Solution Accepted

    @Andaloussi you won't need to use Studio during the exam really. You can have it open to look up things but you won't need to do any work during the exam. 50 questions in 90 minutes so you can guess there is not a lot of time for building a process. 

     

    Regarding the slowing down we want to investigate this further to see if it is a bug we need to fix for sure.

    In case you are not using it then you can log out by simply selecting "cloud" from the menu - alternatively have you tried just deleting the cloud repo (just an idea but be careful I don't know if/how you can bring it back)? Not sure if you are using wisdom of the crowds but you might want to opt out of it for a test (Settings - preferences - recommender - untick boxes - then restart). Last but not least have you had the chance to test on different networks with higher or lower speed? Just curious if that has an influence on the issue...

    Cheers, K.

Answers

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,446  Community Manager

    hello @Andaloussi - can you please be more specific when you say "slows down"? And RapidMiner works just fine offline; feel free to just disconnect from the internet to work if you desire.

     

    Scott

     

  • AndaloussiAndaloussi RapidMiner Certified Analyst, Member Posts: 3 Contributor I

    Hello @sgenzer, what I mean by 'slows down' : when I drag an operator to the design view it doesn't appear instantly but it takes abt 5 to 10 seconds...same when I run a process it can take till 1 mn for complex one!!

    I know that I can simply disconnect from internet to work comfortably, but it's not the best solution for many reasons that anyone can guess.

    My question is, if there is any parameters setting which allows to work locally on the desktop without being automatically logged to the RM cloud?

    In fact one of my fears is that I would like to pass my RM certification and I need to be logged in at the same time i'm working on RM.

     

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,446  Community Manager

    hi @Andaloussi sorry for the delayed response. By chance do you have the Deep Learning operator in your process? Can you please send me your rapidminer-studio.log file? You can just send it by DM here on the community.

     

    Thanks.


    Scott

     

  • SGolbertSGolbert RapidMiner Certified Analyst, Member Posts: 340   Unicorn

    Hi @Andaloussi,

     

     

    Could it be that you don't have a lot of RAM in your computer? This shouldn't happen at all.

     

     

    Regarding the exam, it is useful to have Studio open to search for operators and their documentation. Maybe you can take the exam using another computer?

     

    Regards,

    Sebastian

Sign In or Register to comment.