Rapidminer studio dependency not fullfilled

abhi97660abhi97660 Member Posts: 11 Contributor II
edited December 2018 in Help

Hi,

I am using RM Studio 8.2 and RM Server 8.2.

After building its running properly in 8.2 (studio and server) but not running in 8.1.

To run on other versions for compatibility I have added 

dependencies {
rapidminer '8.2.0'
rapidminer '8.1.0'
rapidminer '8.1.1'
}

 in my build.gradle file

and tried testing on 8.1 version  I am still getting error message as:

"dependency not fulfilled. Extension needs RM studio 8.1.001,  RM Studio version is 8.1.000".

I have added 8.1.0 in gradle should this be enough or is there something I have to specifically add...?

Any suggestion what could be added in gradle files to include all the point versions eg: 8.1.(001, 000) ...?

 

Tagged:

Best Answers

  • abhi97660abhi97660 Posts: 11 Contributor II
    Solution Accepted

    Hi ,

    Forgot to mention the above post is about custom extension development and its compatibility testing in different versions

  • rfuentealbarfuentealba Posts: 218   Unicorn
    Solution Accepted
    Hello,

    I read it somewhere, don't remember where: Try putting the lowest version of RapidMiner that is required by your extension, or no version at all.

    Is that feasible for your use case?

    All the best,

Answers

  • jczogallajczogalla Employee, Member Posts: 93   RM Engineering

    Hi @abhi97660!

    If you want to be backwards compatible, just use the lowest needed version in the dependency.

     

    If you want to build against the newest version but also be backwards compatible, use the highest version and add the following to your gradle build file:

    afterEvaluate{
    jar {
    manifest.attributes("RapidMiner-Version": "<lowest.version>")
    }
    }

    Please keep in mind that in that case, you have to take care of any incompatibilities like API changes, moved classes, etc.

     

    Hope that helps!
    Jan

Sign In or Register to comment.