ANNOUNCEMENT: RAPIDMINER 9.1 HAS JUST BEEN RELEASED!   PLEASE DOWNLOAD AND GIVE FEEDBACK. ENJOY AND HAPPY RAPIDMINING!   -- @sgenzer – Community Manager

How can I crawl more than one web page?

pix123pix123 Member Posts: 15 Contributor I
edited December 6 in Help
Hi there, I am looking to collect the text data about a movie review, there are several pages of reviews and I would like to collect the first 10. I have set up a very basic web crawler as I want to get the data in txt data to do some text pre-processing and mining instead of crawling each time. However I only seem to pick up on the first page of reviews, please can you take a look and advise?

<?xml version="1.0" encoding="UTF-8"?><process version="9.0.003">
  <context>
    <input/>
    <output/>
    <macros/>
  </context>
  <operator activated="true" class="process" compatibility="6.0.002" expanded="true" name="Process">
    <process expanded="true">
      <operator activated="true" class="web:crawl_web" compatibility="9.0.000" expanded="true" height="68" name="Crawl Web" width="90" x="112" y="75">
        <parameter key="url" value="https://www.rottentomatoes.com/m/chef_2014/reviews/"/>
        <list key="crawling_rules">
          <parameter key="store_with_matching_url" value=".*chef_2014.*"/>
          <parameter key="follow_link_with_matching_url" value=".*chef_2014.*"/>
        </list>
        <parameter key="output_dir" value="C:\rottentomatoes reviews &amp; Clustering\Rapidminer Output"/>
        <parameter key="max_pages" value="10"/>
        <parameter key="max_depth" value="4"/>
        <parameter key="max_page_size" value="1000"/>
        <parameter key="user_agent" value="test"/>
      </operator>
      <connect from_op="Crawl Web" from_port="Example Set" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
    </process>
  </operator>
</process>


Best Answer

Answers

  • pix123pix123 Member Posts: 15 Contributor I
    @Telcontar120 Thank you for this
  • pix123pix123 Member Posts: 15 Contributor I
    @Telcontar120 Is there a way to export the ISOOObject Collection files to CSV?
  • sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager Posts: 1,886  Community Manager
    @Telcontar120 - AFAIK there are no plans to update the web mining extension in the near-to-medium future BUT there is a newly-certified RapidMiner Expert I know who lives in a gloriously beautiful country called Chile who may be coerced into porting Selenium into a RapidMiner extension.. :wink: @rfuentealba

    Scott

    rfuentealba
  • Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 882   Unicorn
    I'd loooove a Selenium extension for RapidMiner!  That would be epic @rfuentealba !
    FYI, @sgenzer I did confirm with Helge that this is a bug with the Crawl Web operator.  It looks like it is related to https pages (which is a shame since that is like 90% of the web these days).

    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
    rfuentealbasgenzer
  • rfuentealbarfuentealba Moderator, RapidMiner Certified Analyst, Member Posts: 214   Unicorn
    I have good news: the Selenium extension for RapidMiner is in pre-alpha stage, we at Pegasus are investing a lot of time in building something that can, for now, duplicate the behavior of what already exists on RapidMiner. As we spoke with @sgenzer at RapidMiner Wisdom is that the extension will have blocks that perform certain actions such as "clicking on certain button", "retrieving the content from certain element, class or id", "store the content into a document", "waiting for the site to be ready before doing such things", "going back to the previous page". So you can build your navigation flow.

    It is taking me ages because of my current travel plans (guess what? more delays!), but I have plans to release it at some point in January.
    sgenzer
  • sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager Posts: 1,886  Community Manager
    :smiley: :smiley: :smiley: :smiley:
Sign In or Register to comment.