The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.

Time Series Gaps for Arima - How to fill them?

pedrodomingosdvpedrodomingosdv Member Posts: 17 Contributor I
edited January 2019 in Help
I using auto-arima (operator R Script) with some success, but I'm facing now an issue. My data sometimes is not provided with all dates. For example, my data is recorded by week and to be in a date format I use the every monday of each week.

Tipically I do not have gaps, but ever in a while I have and it takes a lot of time to create those rows for every runs I have to do. So basically I would like to know if there are any ways of filling the missing date points in Rapidminer. It would be helpful because I want to replace those gaps with interpolation or average.

I see that there are some operators that are related with similar issues. I thought that "Fill Data Gaps" might be the one, but every time I set the step size as 7 the process freezes and no outcome is delivered at all.

Enclosed an example of the data source in excel and a short process file.


Best Answers

  • Options
    pedrodomingosdvpedrodomingosdv Member Posts: 17 Contributor I
    Solution Accepted
    Hi Marco, I'm Portuguese and looking to your name I guess that you are too :smile:
    Sorry for the late reply, but I've been away from desk.

    I tried to adapt the process you supplied, but with no success at all.

    Two questions:
    1) Enclosed the "adapted" process. What am I doing wrong? I feel that I need a couple of spare hours to understand the all process and that's why I did few adaptations.
    2) Being able to have 1) correct, how can I apply that to fill my time series?
    Is the output supposed to be already the time series with no gaps?

    The output I'm getting doesn't seem to me to be correct.



  • Options
    lionelderkrikorlionelderkrikor Moderator, RapidMiner Certified Analyst, Member Posts: 1,195 Unicorn
    Hi @pedrodomingosdv,

    Have you tried the Replace Missing Values (Series) operator of the Time Series module ?

    Hope it helps,



  • Options
    pedrodomingosdvpedrodomingosdv Member Posts: 17 Contributor I
    Hi guys,
    Thanks for your replies.
    @MarcoBarradas I think that your proposal it is more close to what I need.

    Though I'm still struggling to make it fit in my process.

  • Options
    pedrodomingosdvpedrodomingosdv Member Posts: 17 Contributor I
    Hi Marco,
    Done :smile:
    I two small made a few changes to your process:
    1) "Adjust Date" was removed. That as adding one day to each row and in the end it was causing an  incorrect "join"
    2) In the last part of the process I just added "Nominal to Date" to have a dates

  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
    hi @MarcoBarradas I'm checking with @mschmitz on the macro in Create ExampleSet...
Sign In or Register to comment.