The Altair Community is migrating to a new platform to provide a better experience for you. The RapidMiner Community will merge with the Altair Community at the same time. In preparation for the migration, both communities are on read-only mode from July 15th - July 24th, 2024. Technical support via cases will continue to work as is. For any urgent requests from Students/Faculty members, please submit the form linked here.

RapidMiner Set-Up

freyfrey Member Posts: 1 Newbie
edited January 2019 in Help

first of all, I am very new to Linux and RapidMiner - so sorry right away.
I try to start RapidMiner and loaded the version of the website.

frey@linux:~$ java --version
java 10.0.2 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)

frey@linux:~$ echo $PATH

frey@linux:~$ $JAVA_HOME
bash: /usr/lib/jvm/java-10-oracle: Is a directory

frey@linux:~/RapidMiner$ ./
RAPIDMINER_HOME is not set. Trying the directory '/home/frey/RapidMiner'...
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
    at com.rapidminer.license.verification.JarVerifier.verify(
    at com.rapidminer.launcher.GUILauncher.main(
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
    at java.base/java.lang.ClassLoader.loadClass(
    ... 2 more

Maybe someone can help me?
I don't understand the PATH variable, is it right?




  • Options
    jay123jay123 Member Posts: 2 Contributor I
    edited January 2019
    Your PATH variable shouldn't have jdk-install in it. Usually when you `echo $PATH` it should produce something as follows:
    -bash: /usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/user1/.local/bin:/home/user1/bin<br>
    So my guess is that you haven't set your PATH properly. It has nothing to do with Rapidminer, that is a linux question. The RAPIDMINER_HOME is also not set, which means it wasn't properly installed. You need to fix the PATH (which would include the the path to java bin) and then re-install Rapidminer.
  • Options
    sgenzersgenzer Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,959 Community Manager
    also please note that RapidMiner does not support Java 10. You must have Java 8 to run it.


  • Options
    Robi_MeRobi_Me Member Posts: 32 Maven
    This one had me baffled until I actually read the install instructions and saw that Java 8 was supported. 
Sign In or Register to comment.