Options

Execute process every minute

kylejohnsonkylejohnson Member Posts: 7 Newbie
Hello,

I am trying to execute a process every minute.  I tried using the Loop Operator (3 iterations) by putting the Delay Operator (60,000 ms) and Run Process inside of it but it would wait 1 minute and then run the process three times.  I am trying to get it to wait 1 minute, run the process once, wait another minute, run the process again and then wait another minute and run the process a third time.  My other idea was to use a macro but I am unfamiliar with those.  Thank you in advance for your time and advice!

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,517 RM Data Scientist
    Hi,
    This sounds like a super normal use case for server, then you can also use execute process or use the built in cron-schedule.

    Is Server an option? It's free for academia.

    Best,
    Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    kylejohnsonkylejohnson Member Posts: 7 Newbie
    I did not know the server was free for academia.  That is definitely a possibility but honestly I would prefer to keep it local if possible.  Is there a way to make it work without the server?
  • Options
    kylejohnsonkylejohnson Member Posts: 7 Newbie
    I also tried putting the Delay opperator inside the process itself but that gave me the same outcome where it waited and then ran the loop three times in a row.
  • Options
    IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,751 RM Founder
    edited April 2019
    Looks like the loop is parallelized - there should be an option in the Loop operator's parameters "enable parallel execution".  Try to run this without parallelization.
    Cheers,
    Ingo
  • Options
    kylejohnsonkylejohnson Member Posts: 7 Newbie
    I don't see an option to enable parallel execution; there is only one to "reuse results".  However I think I got it to work by selecting "reuse results" and moving the Delay to after the Execute Process within the Loop.
  • Options
    Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,635 Unicorn
    You need to enable expert view to see the advanced parameters (click the little icon of the guy in the graduation cap in the parameters panel where it says "show advanced parameters"), and then the "enable parallel execution" option will be visible.

    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
Sign In or Register to comment.