New Linux (Ubuntu 18.04.2) Installation - RapidMiner Fails On Startup

User34031User34031 Member Posts: 3 Contributor I
edited April 8 in Help
Hello,

Just downloaded the Linux version of RapidMiner (Free) - Studio Version 9.2. When running the ./RapidMiner-Studio.sh, RapidMiner launches but hangs on 'Initializing Plugin GUI'. The last entry in the terminal is:
INFO: Community repository 'Training Resources' added.

I have read several articles and have taken the following actions:

Changed permissions:
set chmod +x  RapidMiner-Studio.sh

Edited /etc/environment to include the following line:
JAVA_HOME="java-8-openjdk-amd64"
source /etc/environment 

echo $JAVA_HOME  provides the following results:
java-8-openjdk-amd64

Please note, I also have OpenJDK 10.0.2 installed.

In addition, I edited the RapidMiner-Studio.sh and added the following to the lines below:  --add-modules=java.xml.bind 

    # Launch Studio
    LAUNCH=0
    if [ $# -gt 0 ]; then
      eval \"$JAVA\" --add-modules=java.xml.bind $JVM_OPTIONS -cp \"${rmClasspath}\" com.rapidminer.launcher.GUILauncher \"$@\"
    else
      eval \"$JAVA\" --add-modules=java.xml.bind $JVM_OPTIONS -cp \"${rmClasspath}\" com.rapidminer.launcher.GUILauncher
    fi

    if [ $? -eq 2 ]
    then
        echo RapidMiner Studio will now relaunch 
        LAUNCH=1
    fi
done

I have also tried deleting all of the files in the .RapidMiner folder and relaunching RapidMiner.

Lastly, I tried running RapidMiner without loading the extensions (Disable extension button) and RapidMiner continues hangs on 'Initializing Plugin GUI'.

Any guidance would be greatly appreciated.

Thanks!

Answers

  • User34031User34031 Member Posts: 3 Contributor I
    ***FIXED***

    Changed /etc/environment to include the path:
    JAVA_HOME="/usr/lib/jvm/java-8-openjdk-amd64"
    Also had to remove both references from the RapidMiner-Studio.sh script and return it back to the original state.
    --add-modules=java.xml.bind
    Thanks!
    David_AsgenzerIngoRM
  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 269   Unicorn
    Hi,

    you might also need to install the libopenjfx-java package if not installed yet.

    Regards,
    Balázs
    yyhuang
  • User34031User34031 Member Posts: 3 Contributor I
    Thanks, Balázs! Seems to be working but I greatly appreciate the suggestion.
    Best regards,
    earle
Sign In or Register to comment.