Replacing special characters when text mining

robinrobin Member Posts: 87   Unicorn
edited June 15 in Help
Hi

I am attempting to replace special characters inside of a dataset but not having much luck. 

André Shoémaker
Adrié Spéllman

It seems as though RapidMiner is unable to understand those characters and is simply marking them as �. Non of the replace operators can seem to fix this issue. 

Should I be doing this inside of a generate attributes operator to account for this or is there a better way?


Best Answers

Answers

  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 269   Unicorn
    Hi!

    Where is your dataset coming from? Operators like Read CSV that import external data have an "encoding" parameter. If you set the encoding correctly for your data import, you'll see all special characters.

    Regards,
    Balázs
    robin
  • rfuentealbarfuentealba Moderator, RapidMiner Certified Analyst, Member, University Professor Posts: 361   Unicorn
    Another thing: -I is a capital "i".
Sign In or Register to comment.