Options

RM 9.5 and 9.6 Fail to Start

btibertbtibert Member, University Professor Posts: 146 Guru
I am getting a crash report, attached, when I attempt to open 9.5.  As such, I upgraded to 9.6 but am still getting the error.  I can start in safe mode, but this has never happened to me before.  Any thoughts?  Is there a formal place I can submit for technical support?


Best Answer

Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,508 RM Data Scientist
    Hi,
    this should be somewhat related to deep learning extension. Can you temporarly delete this and check if it works?

    Best,
    Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    btibertbtibert Member, University Professor Posts: 146 Guru
    Thanks for the note.  What is the best way to do that?  Safe mode?  I am on my other machine at school at the moment, so I will take a look tomorrow.  Thanks, I appreciate it.
  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,508 RM Data Scientist
    edited March 2020
    Hi @btibert,
    in your .Rapidminer folder (/home/btilbert/.RapidMiner) you have a folder called extensions. Somewhere there is the deep learning jar (maybe under managed?). Just delete/copy/put it somewhere else and restart studio.

    Cheers,
    Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    btibertbtibert Member, University Professor Posts: 146 Guru
    Thanks, I actually went ahead and started RM in safe mode, disabled the extension there, and restarted without a crash.  What is bizarre is that I have the DL extension on my other machine, and that does not create an issue.   

    Stepping back, is there a bug with the deep learning extension?
  • Options
    btibertbtibert Member, University Professor Posts: 146 Guru
    Thanks @sgenzer that did the trick (updating the DL extension).  And thanks for the note on the product feedback area!
  • Options
    pschlunderpschlunder Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, RMResearcher, Member Posts: 96 RM Research
    edited March 2020
    glad to hear the update solved your problem. Very likely it was caused due to an incompatibility with macOS Catalina. This was fixed in version 0.9.3. Sorry for the inconvenience.

    Please note, that due to a general movement in the market away from providing GPU drivers for Deep Learning libraries on macOS, we also had to drop this support. Hence on macOS we can only support Deep Learning executions on CPU. But still you can build and test your processes on your mac and push them to a RapidMiner Server with GPUs available and make use of them, there.
Sign In or Register to comment.