RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

logistic regression - Model training error (H2O)

Shaila_SegalShaila_Segal Member Posts: 4 Contributor I
edited March 3 in Help
I am using RapidMiner 9.6.000 and I am having the same issue with the Model training error (H2O) with my logistic regression function.  I have tried the unchecking compute p-value and it hasn't fixed it.  Is there something else I can do in the newest version?
Tagged:
[Deleted User]Jasmine_

Best Answer

Answers

  • varunm1varunm1 Moderator, Member Posts: 1,197   Unicorn
    edited March 3
    Hello @Shaila_Segal

    Can you check the input going into a logistic regression operator? The error represents that there is only one label going inside the logistic regression operator. As prediction cannot be done with one label it might be throwing an error.

    You can check the input by right-clicking on the logistic regression operator and select "breakpoint before". Once you run the process you can see the data going into the operator and in statistics you can see the label statistics representing the number of samples in each class.

    If you want us to check, please provide us with the process by going to FILE --> Export process and attach that .rmp file here. Please also provide us with data.


    Regards,
    Varun
    https://www.varunmandalapu.com/

    Be Safe. Follow precautions and Maintain Social Distancing

    Jasmine_
  • Shaila_SegalShaila_Segal Member Posts: 4 Contributor I
    I set one variable in the set role function? but I am pretty sure that is what I was supposed to do.  
    Jasmine_
  • Shaila_SegalShaila_Segal Member Posts: 4 Contributor I
    Yes that worked! thank you(:
    Jasmine_
Sign In or Register to comment.