Error in model ops: 'GREATEST' is not a recognized built-in function name.

christos_karraschristos_karras Member Posts: 33  Guru
edited March 25 in Help
I tried to deploy a custom model in Model Ops on a server that was recently updated to version 9.6. I created a deployment, and then tried to add a model to the deployment. After a few minutes, I get this error message (same error if I switch to the other tabs):

'GREATEST' is not a recognized built-in function name


"GREATEST" is not a word used in anything we have developed, so I assume it's part of the internal Model Ops code. 
I tried search the files generated under the repository folder associated to Model Ops, but did not find anything there.

Also, I was previously able to deploy the same model to a local repository (RapidMiner Studio)

I also get the same error if I try to deploy a model trained by AutoModel, from the sample dataset //Samples/data/Polynomial

How can I investigate?



Thanks

Best Answer

  • IngoRMIngoRM Posts: 1,736  RM Founder
    Solution Accepted
    Model Ops is actually somewhat independent of Server which is why it is part of the Studio documentation.  But you are right on the requirements: this is indeed an oversight and should go into the docs asap.  Sorry for the inconvenience.
    Currently there are no plans for additional DB.  But please note that you can use two different systems if you like: one for the Server and a different one for storing the ops data.
    Hope this helps,
    Ingo

Answers

  • BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 417   Unicorn
    Hi,

    GREATEST is a SQL function, but it's probably not implemented in every database type in the same manner.
    Which database server is your RM Server using?

    Regards,
    Balázs
  • IngoRMIngoRM Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, Community Manager, RMResearcher, Member, University Professor Posts: 1,736  RM Founder
    I am thinking the same, @BalazsBarany.  But probably the problem is not the Server database, but the one used for logging for Model Ops.  Currently Model Ops only supports MySQL and Postgres.
    Hope this helps,
    Ingo
  • christos_karraschristos_karras Member Posts: 33  Guru
    Hi @IngoRM@BalazsBarany,

    Yes that seems to be a likely explanation. The server has been using SQL Server for its operations database (which should be supported based on the documentation https://docs.rapidminer.com/latest/server/install/) and we assumed we could use the same server for Model Ops. I did not find anything in the documentation about more limited database support for Model Ops, is this documented? The installation guide in https://docs.rapidminer.com/latest/studio/guided/deployments/ shows PostgreSQL as an example, but there's no mention that it's a requirement. Is there any systems requirements specifically for Model Ops, to ensure we don't have any other limitations that would prevent using it?

    Thanks
  • christos_karraschristos_karras Member Posts: 33  Guru
    Also I think this document should be updated to include Model Ops (components and requirements): https://docs.rapidminer.com/latest/server/configure/server-overview.html

    @IngoRM You mentioned that Model Ops "currently" supports MySQL and Postgres, is there a roadmap for supporting other databases? (I'm wondering if we should wait for MS SQL Support or just migrate to Postgres)

    Thanks
    Andy3
Sign In or Register to comment.