πŸŽ‰ πŸŽ‰. RAPIDMINER 9.8 IS OUT!!! πŸŽ‰ πŸŽ‰

RapidMiner 9.8 continues to innovate in data science collaboration, connectivity and governance

CLICK HERE TO DOWNLOAD

how to display all value culumns in Heatmap?

ntouvntouv Member Posts: 2 Newbie
edited March 30 in Help
I am facing the following problem:

working with a dataset of 94 columns and 750 rows and when i choose plot style Heatmap in Visualization, even though i add all columns in the value columns menu, when the graph is displayed not all of columns are displayed. maybe around 50 of them!

(you can see in attached image attributes already selected but not displayed )



i have tried inverting the chart but no luck either.

from what i read in rapidminer.com/latest/studio/releases/changes-9.2.1
Visualizations: Heatmaps can now support 500 value columns at the same time, up from 400.


what am i missing?
is there a way to come over this?

thanks for your time and help in advance!

p.s. i am using version 9.6 both on macos and fedora.


Best Answer

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,949   RM Engineering
    Solution Accepted
    Hi,

    No, the graphs are squeezed right now to always fit the screen. So short of dragging Studio onto a 4K monitor, your only option is to export to an image with a huge size to get them non-squeezed.
    Unfortunately, scrolling is not possible at the moment, but I will add this to my list of improvements for the visualizations.

    Regards,
    Marco
    ntouv

Answers

  • Marco_BoeckMarco_Boeck Team Lead Software Engineering Administrator, Moderator, Employee, Member, University Professor Posts: 1,949   RM Engineering
    edited March 31
    Hi,

    It works fine for me, I just tested it again and simply added a Generate Data operator, set its number of attributes to 500, and added all except the label.
    Two things come to mind:
    1. You are using aggregation in the screenshot above. That means it will reduce the number of rows to n where n = number of distinct values in your aggregation attribute. Your chart in the screenshot is still inverted)
    2. The axis labels skip elements if the space is insufficient. The actual data is there however, and you can see the labels when you zoom in. See the following two screenshots of the 500 columns. Not all of them have names on the axis, but they are all displayed. When you zoom in, the axis labels appear due to more available space.



    Regards,
    Marco
    sgenzerMarcoBarradas
  • ntouvntouv Member Posts: 2 Newbie
    Hi Marco and thanks for your respond!

    as for 1
    "You are using aggregation in the screenshot above. That means it will reduce the number of rows to n where n = number of distinct values in your aggregation attribute. Your chart in the screenshot is still inverted)"

    i only enabled aggregation in hope of reducing the image dimension so that it would fit in the screen.i know it's on and the chart is inverted.
    but even disabling aggregation and re inverting the chart still not all columns are displayed.



    as for 2.
    "The axis labels skip elements if the space is insufficient. The actual data is there however, and you can see the labels when you zoom in. See the following two screenshots of the 500 columns. Not all of them have names on the axis, but they are all displayed. When you zoom in, the axis labels appear due to more available space."

    I thought it has something to do with the available display space as when you add more columns ,after a certain number ,instead of squeezing them, the space between columns spreads. (sorry if my English don't make proper sense).

    is there a way when i zoom in to scroll horizontally to see all columns?
    or maybe increasing the available space so that the chart properly fits?

    the only workaround i found was exporting the chart to jpeg. this way i can see all columns displayed!

    thanks again for your time.

Sign In or Register to comment.