RapidMiner 9.7 is Now Available

Lots of amazing new improvements including true version control! Learn more about what's new here.

CLICK HERE TO DOWNLOAD

Disconnected RM Server Repository at Azure

AlphaPiAlphaPi Member Posts: 10 Contributor II
edited May 14 in Help
Hello everyone,

I used to run some processes through RM Studio on a VM, using a connection to Azure with a free trial. My free trial expired. Does anyone know, if the connection will be restored and if i will retrieve my data in case of a payment? Or everything is gone? 

Thanks in advance

Answers

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,938  Community Manager
    hi @AlphaPi hmm that is a very good question. Let me ping our internal team on this.
  • AlphaPiAlphaPi Member Posts: 10 Contributor II
    Hello everyone,

    I restarted my VM and i saw my data in RapidMiner Studio, through the connection with the server, using the Repository URL. But that was for few minutes. Now, i can not access the RapidMiner Server Web UI. Is this a problem of the IP or the port or i have an access problem? 

    Also, i post a screenshot to help you understand my problem. 

    Thanks in advance! 
  • jpuentejpuente Employee, Member Posts: 37  RM Product Management
    Hi. So, what happens when you click on that Web UI link? Does it show an error? Also, can you connect from Studio? In Studio, you'll probably need to reconfigure the connection IP as you say.
  • AlphaPiAlphaPi Member Posts: 10 Contributor II
    Hello and thanks for the response,

    The error i get when i click on that Web UI link is "HTTP ERROR 404". 

    I cannot be connected from the Studio, either. The error is the following: 


    By reconfiguring the connection IP, you mean to change the IP of my VM, or just the port? 

  • AlphaPiAlphaPi Member Posts: 10 Contributor II
    Hello @sgenzer,

    Do you have any updates from your internal team, for my issue? 

  • sgenzersgenzer 12Administrator, Moderator, Employee, RapidMiner Certified Analyst, Community Manager, Member, University Professor, PM Moderator Posts: 2,938  Community Manager
    hi @AlphaPi unfortunately I do not. I am cc'ing @jpuente and @aschaferdiek to see if they have any new information.

    Scott
  • jpuentejpuente Employee, Member Posts: 37  RM Product Management
    Hi @AlphaPi
    Sorry for the late response. It looks like the Server did not start, or at least not in the right way. Restarting the VM could be one option. A better one, looking a bit more into the details, is to click on the "Docker Deployment Manager" link. There, there's a list of all the services running on the machine. All of them should be up, you can check the Server status and it's logs (post them please if you see an error). You can also restart the Server service from there and see the result. Please do that and post the logs or results. 
    aschaferdiek
  • AlphaPiAlphaPi Member Posts: 10 Contributor II
    Hello @jpuente,

    Thank you for the response. I have restarted the VM lots of times. 
    I am trying to get into the "Docker Deployment Manager" link, but that needs credentials. I tried to enter with my passwords but i get a "401 Authorization Required" error. 

    At this point, let me remind you again my problem in a timeline: 
    I used to have a free trial for Azure, which has been expired and now i have a new subscription, from where i use the same VM and the same IP, which i had during the free trial and used to work very good. 
    My RapidMiner Server license has not been expired. 

    When i created the new subscription and started again the VM, for some minutes i had the chance to log in in the Server and see my previous executions. Also the Azure Repository was connected in my RapidMiner Studio again. But this access was for some minutes only. 

    I hope to find a solution soon because i need to find my trained models again. In case that my problem situation is not clear to you, let me clarify it more. 

    Thanks in advance!
Sign In or Register to comment.