Array Index Error during 'Loading Excel File'

HacHac Member Posts: 9 Newbie
edited July 2020 in Help
I get the following error in loading an Excel file that was created with MS Access.
  • Exception: java.lang.ArrayIndexOutOfBoundsException
  • Message: 1
  • Stack trace:
  • com.rapidminer.operator.nio.model.xlsx.XlsxNumberFormats.setCellNumberFormatId(XlsxNumberFormats.java:65)
  • com.rapidminer.operator.nio.model.xlsx.XlsxNumberFormatParser.parseNumberFormats(XlsxNumberFormatParser.java:144)
  • com.rapidminer.operator.nio.model.xlsx.XlsxResultSet.(XlsxResultSet.java:248)
  • com.rapidminer.operator.nio.model.xlsx.XlsxResultSet.(XlsxResultSet.java:329)
  • com.rapidminer.operator.nio.model.xlsx.XlsxSheetTableModel.(XlsxSheetTableModel.java:113)
  • com.rapidminer.operator.nio.model.ExcelResultSetConfiguration.createExcelTableModel(ExcelResultSetConfiguration.java:216)
  • com.rapidminer.operator.nio.model.ExcelResultSetConfiguration.createExcelTableModel(ExcelResultSetConfiguration.java:193)
  • com.rapidminer.studio.io.data.internal.file.excel.ExcelSheetSelectionPanelModel$1.loadTableModel(ExcelSheetSelectionPanelModel.java:212)
  • com.rapidminer.studio.io.data.internal.file.excel.ExcelSheetSelectionPanelModel$1.run(ExcelSheetSelectionPanelModel.java:176)
  • com.rapidminer.gui.tools.ProgressThread$3.run(ProgressThread.java:586)
  • java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
  • java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
  • java.lang.Thread.run(Thread.java:748)


Best Answer


  • Options
    HacHac Member Posts: 9 Newbie
    I have 9.7 and I am using an educational version. I am getting the same error with a much smaller file.  I do not know the limits of the version I have.
  • Options
    jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
    If you have an educational license you have no limit on the data size (check About RapidMiner and there it will be written what is your license). The issue may be to do with your environment, e. g. the version of Java on your computer or with one of the extensions being fault. Try saving the Excel file as CSV and see if you have the same problem reading it in this form (as some of your columns have # signs, make sure that when you read the CSV file in, either you remove the # characters from the column names prior to exporting it from Excel or click off the Read CSV option to use it as a comment character). 
  • Options
    HacHac Member Posts: 9 Newbie
    I have found that the number of lines is not the problem; the number of columns is the issue.  I can only use 16 columns for a file import.
  • Options
    jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
    Great you've found the problem, however, I also use educational license and do not have such restrictions. I regularly import very large CSV and Excel files.
  • Options
    HacHac Member Posts: 9 Newbie
    The questions now are - why do I have the restriction and can it be changed?
Sign In or Register to comment.