Missing attributes

bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 57 University Professor
Hello,

I am having the classical missing attributes problem. I have three nominal attributes, and I want to turn two into numerical, and one into text. When I use nominal to numerical only the attribute I want to turn in to text shows up. I tried the "synchronize meta data with real data" to no avail: the attributes do appear after I select this option, but then RM converts each entry into a new attribute. 

Any help is appreciated. 
Best,
Bernardo



Tagged:

Best Answer

Answers

  • bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 57 University Professor
    Dear Harshit,

    thank you very much for your reply! Your suggestion solved the problem. What upsets me is that I was aware of the problem, and cleaned cluster using filter examples. It did not work. 

    Even when I reproduced your solution the attributes would not appear, and I used inverse selection to save the day. There is something weird with RapidMiner regarding the display of attributes. 

    Thanks again, and I wish you a great day. 

    Bernardo
    hbajpai
  • MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,321 RM Data Scientist
    Hi,
    if you mouse over the ports you can see the meta data which is transfered. This way you can figure out which operator is forgetting to add the attribute to the meta data.
    Usually this is a read operator, where we have a harder time to know what attributes are in the file.

    Best,
    Martin
    - Head of Data Science Services at RapidMiner -
    Dortmund, Germany
  • bernardo_pagnonbernardo_pagnon Member, University Professor Posts: 57 University Professor
    That is a nice tip, thanks Martin!
Sign In or Register to comment.