🎉 🎉 RAPIDMINER 9.10 IS OUT!!! 🎉🎉

Download the latest version helping analytics teams accelerate time-to-value for streaming and IIOT use cases.

CLICK HERE TO DOWNLOAD

Charts - label visibility issue - Y axis

maciekmaciek Member Posts: 11 Contributor II
edited September 2020 in Help
Dear RapidMiner community,

I try to save a chart to a file in a following way:

1. I don't want the chart title to be visible
2. I want to make labels of the Y axis larger, and I set the font size to 20 or greater: Y-Axis -> Axis style -> Labels style -> Label font

The "0.72" number is now not completely visible (see attached file).




Right now I do the following as a work around: I make the "Title" visible and set the font color to white, but I have a feeling it should be just working.

And here is the code:

<?xml version="1.0" encoding="UTF-8"?><process version="9.7.000">
  <context>
    <input/>
    <output/>
    <macros/>
  </context>
  <operator activated="true" class="process" compatibility="9.7.000" expanded="true" name="Process">
    <parameter key="logverbosity" value="init"/>
    <parameter key="random_seed" value="2001"/>
    <parameter key="send_mail" value="never"/>
    <parameter key="notification_email" value=""/>
    <parameter key="process_duration_for_mail" value="30"/>
    <parameter key="encoding" value="SYSTEM"/>
    <process expanded="true">
      <operator activated="true" class="utility:create_exampleset" compatibility="9.7.000" expanded="true" height="68" name="Create ExampleSet" width="90" x="45" y="136">
        <parameter key="generator_type" value="comma separated text"/>
        <parameter key="number_of_examples" value="100"/>
        <parameter key="use_stepsize" value="false"/>
        <list key="function_descriptions"/>
        <parameter key="add_id_attribute" value="false"/>
        <list key="numeric_series_configuration"/>
        <list key="date_series_configuration"/>
        <list key="date_series_configuration (interval)"/>
        <parameter key="date_format" value="yyyy-MM-dd HH:mm:ss"/>
        <parameter key="time_zone" value="SYSTEM"/>
        <parameter key="input_csv_text" value="id,value&#10;1,0.7034&#10;2,0.6502&#10;3,0.6212&#10;4,0.5734&#10;5,0.5553"/>
        <parameter key="column_separator" value=","/>
        <parameter key="parse_all_as_nominal" value="false"/>
        <parameter key="decimal_point_character" value="."/>
        <parameter key="trim_attribute_names" value="true"/>
      </operator>
      <connect from_op="Create ExampleSet" from_port="output" to_port="result 1"/>
      <portSpacing port="source_input 1" spacing="0"/>
      <portSpacing port="sink_result 1" spacing="0"/>
      <portSpacing port="sink_result 2" spacing="0"/>
    </process>
  </operator>
</process>



Do you think there is any other option of making it work? I generate a lot of charts and I have a lot of an additional work to do because of that.

Best regards
Maciek


Answers

  • VanlalVanlal Member Posts: 12 Contributor II
    Hi maciek,
      I do not have any problem when i tried your settings... 
    You can import chartconfiguration.json 
    maciek
  • maciekmaciek Member Posts: 11 Contributor II
    Dear @Vanlal,

    thank you for your answer.

    Please, look in the upper-left corner of your graphics - the number is not completely visible. When you increase the size of the font the problem gets more visible.




    Best regards
    Maciek
Sign In or Register to comment.