changing data type after loop file or zip reading

ekhlasekhlas Member Posts: 2 Newbie
edited September 2020 in Help

after reading the loop zip file and trying to append multiple data set, data types don't match even though the same column name? 
i tried selecting attribute before the append but the problem is data attributes don't appear.
can i find more suggestion ?


  • Options
    David_ADavid_A Administrator, Moderator, Employee, RMResearcher, Member Posts: 297 RM Research
    Hi @ekhlas ,

    this can happen if the types differ in the files. Typically this happens if you have number columns and then some extra status codes or missing value encodings.

    The simplest solution is to use Append (Robust) or the Append (Superset) operator from the Toolbox extension.
    Afterwards the Parse Numbers operator can be helpful to make sure number columns are correctly recognized.


  • Options
    ekhlasekhlas Member Posts: 2 Newbie
    edited October 2020
    thank you, it worked 
  • Options
    Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,635 Unicorn
    Another option is to import all fields from all files as nominals, and then later after you do the append you can see which fields contain only numerical values and use Parse Numbers at that point.

    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
Sign In or Register to comment.