🎉 🎉. RAPIDMINER 9.8 IS OUT!!! 🎉 🎉

RapidMiner 9.8 continues to innovate in data science collaboration, connectivity and governance

CLICK HERE TO DOWNLOAD

RM 9.8 Deep Learning Extension error

jacobcybulskijacobcybulski Member, University Professor Posts: 249   Unicorn
I am trying to run an included Iris classification with Deep Learning 1.0 extension, ND4j 1.0 with GPU and RM 9.8. Every second run I am getting DL error "SEVERE: Process failed: The provided training data couldn't be parsed correctly. Please ensure that all attributes (except the label) are numerical only." I ensured that the process is 9.8 compatible and I removed the nominal ID attribute. However, it not alter the error until I changed the data split at which point it started working. The error came back when I modified the DL settings (any, e.g. the epochs or learning rate), which again improved itself when I modified the data split. It is persistent. I suspect it is a bug in the extension.

Best Answer

  • jacobcybulskijacobcybulski Member, University Professor Posts: 249   Unicorn
    Solution Accepted
    @pschlunder I have set up a new instance of RM 9.8 from scratch, created a new .RapidMinder folder, set CUDA to 10.1 and started super clean. This time, so far, I am not getting those errors. Perhaps I had too many legacy issues, e.g. the Python extension vanished. All those issues have disappeared. Thanks and let's see...

Answers

  • jacobcybulskijacobcybulski Member, University Professor Posts: 249   Unicorn
    I have tested this with both RM 9.8 and 9.6, with GPU and CPU backend (on Linux). The issue seems to appear only when using the GPU backend. The presence of nominal ID field has no impact on the error (or the lack thereof).
  • pschlunderpschlunder Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, RMResearcher, Member Posts: 85  RM Research
    Hi @jacobcybulski,

    thanks for reporting this problem. Could you provide the process, which CUDA version you are using and the log from Studio please? You can find the latter in your .RapidMiner folder, the log is named: "rapidminer-studio.log".

    Sorry to hear, that you are having these problems, we'll look into it.

    Cheers,
    Philipp
  • hughesfleming68hughesfleming68 Member Posts: 314   Unicorn
    @jacobcybulski. Good idea. I have had some issues transitioning to RM 9.8. Perhaps a fresh install will magically fix things.
Sign In or Register to comment.