πŸŽ‰ πŸŽ‰. RAPIDMINER 9.8 IS OUT!!! πŸŽ‰ πŸŽ‰

RapidMiner 9.8 continues to innovate in data science collaboration, connectivity and governance

CLICK HERE TO DOWNLOAD

How to encode all apostrophes when exporting CSV file

EL75EL75 Member Posts: 26 Contributor II
Hi rapid miner community,
at the end of the process, I use write CSV operator.
When looking at the result, apostrophes are missing:Β Do you know how to encode apostrophe "'Β 'Β " in rapid miner ?Β 
best regards
Tagged:

Best Answers

  • EL75EL75 Member Posts: 26 Contributor II
    Solution Accepted
    Hi Kayman,
    You are definitely right :)
    1 - regarding the export, I've solved the problem. The origin of the issue was that I've added - after the "write CSV operator - a "split data" operator to divise my file in 4 parts, but I've connected the 4 outputs outputs directly to a "store" operator, the connected to the result ports... I've forgotten to add again a "write CSV" operator after each "split data". Sorry for wasting your time, thanks for your patience.

    2- regarding the character [ ' ], you're solution works well :)
    you're the master !
    Wish you the best.
    kaymanMarcoBarradas

Answers

  • kaymankayman Member Posts: 540   Unicorn
    encoding typically means adding a backslash in front of it, so like \'
    Now, these should not disappear in the first place I think, so you might also try to tweak the settings of your export (like untick 'quote nominal values') as this may interfere with your content also
  • EL75EL75 Member Posts: 26 Contributor II
    Hi, Kayman,
    could you tell me where I could do this ? I use the "replace" operator, and I tried different ways using \' but that doesn't work.
    I also untick the 'quote nominal values' without more success.

    By the way, I'm getting mad searching a way of exporting results (CSV file that is the output of the process "write CSV") in a folder on my computer in order to open it with excel. The operator write and store the file in my rapid miner repository...
    thanks again for your help, hope you'll save me from there..
Sign In or Register to comment.