Options

How to hide ".properties" files in the repository browser [Clarified]

jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
edited January 2021 in Help
Since RapidMiner 9.8, ".properties" files (created automatically by RapidMiner) are showing in the (legacy) repository browser. I investigated the use of user interface options in preferences but I cannot see how to switch them off. I am using RM 9.8 on Ubuntu 20.04. 

I thought to clarify this further. Here is a snapshot of a project in RM 9.6:



And here is the same folder as viewed in RM9.8:



As can be seen the annoying ".properties" files are showing everywhere.

Answers

  • Options
    Telcontar120Telcontar120 Moderator, RapidMiner Certified Analyst, RapidMiner Certified Expert, Member Posts: 1,635 Unicorn
    I don't know if you can hide them, but you probably know that you can safely delete them and it doesn't affect anything except the metadata of the users and associated edit dates for the other files in that repo.
    Brian T.
    Lindon Ventures 
    Data Science Consulting from Certified RapidMiner Experts
  • Options
    jacobcybulskijacobcybulski Member, University Professor Posts: 391 Unicorn
    @Telcontar120 yes I know deletion is an option, I'd have to write a script to do so as I have lots in this repository. I have also noticed that if I copy folders from an old repository to the new within RM, these files are no longer created. 
  • Options
    Marco_BoeckMarco_Boeck Administrator, Moderator, Employee, Member, University Professor Posts: 1,996 RM Engineering
    edited February 2021
    Hi,

    Old versions of Studio stored data in your local repository with 2-3 files (e.g. file.ioo, file.properties, and file.md). This was changed for new repositories starting with Studio 9.7. Now your data is stored within a single file only.

    What you show here, can only happen if you place a new repository (created with 9.7+) on a folder that previously contained a repository created before that version. If you copy the files from an old repo into a new repo they will not be copied over, as you noticed.
    If however you already have the new repo placed on a folder where previously an old repo was, this cannot be used anymore. The new repository simply considers the .properties as regular files.

    There is a way to deal with this, but ONLY if you did NOT store anything new / overwrite anything inside the new repository yet.

    1. Close Studio
    2. Go to the folder on your disk, back it up somewhere in case something goes wrong in the following steps
    3. Edit the USER_HOME/.RapidMiner/repositories.xml file, find the entry for the path of the repo that is the problem
    4. Replace it from this: 
      <filesystemRepository>
          <path>/path/to/folder</path>
          <alias>My Repository</alias>
          <encryption-context>default-local-context</encryption-context>
      </filesystemRepository>
    5. To this:
      <localRepository>
      <file>/path/to/folder</file>
      <alias>My Repository</alias>
      </localRepository>
    6. Start Studio again. It should now be an old repository, and you can create a new one, and copy everything over from the old repository to the new one within Studio. Now the files should be gone.

    Regards,
    Marco
Sign In or Register to comment.