ai hub url

Hosseinjin23Hosseinjin23 Member Posts: 2 Contributor I
Hi there, I downloaded the docker-compose files to install the ai hub on windows. I used power shell and entered "docker-compose up -d rm-init-svc" and after the process was completed I entered " docker-compose up -d". This process was also finished without any error. The problem is I don't know how to enter the ai hub? this was on the env. file "PUBLIC_URL=http://platform.rapidminer.com" and even when I changed it to different addresses, I still could not enter ai hub

Best Answer

  • Options
    BalazsBaranyBalazsBarany Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert Posts: 955 Unicorn
    Solution Accepted

    how does your PUBLIC_URL look like? 

    I have these:

    # Public domain of the deployment

    # Public URL of the deployment that will be used for external access (Public domain + protocol + port)

    # Public URL of the SSO endpoint that will be used for external access. In most cases it should be the same as the PUBLIC_URL

    And I made sure that my computer resolves aihub.local to the actual IP address. It is also possible to configure the URLs to an IP address but NOT (localhost). That's needed by Docker. 

    After docker-compose up -d the AI Hub should be running after a few minutes and available under the configured URL - if your browser resolves it the same way as the server machine does.




  • Options
    Hosseinjin23Hosseinjin23 Member Posts: 2 Contributor I
    edited November 2021
    Thank you, I have changed the public domain & Urls to my computer name and the issue is resolved. 
Sign In or Register to comment.