java.lang.IllegalStateException: filter can not be replaced with null filter

bjorn1bjorn1 Member Posts: 2 Newbie
While following the tutorial every time I include the titanic training set I get the following exception: Dec 20, 2021 3:20:45 PM com.rapidminer.gui.tools.ProgressThread$3 run WARNING: Error executing background job Checking repository location (Retrieve): java.lang.IllegalStateException: filter can not be replaced with null filter java.lang.IllegalStateException: filter can not be replaced with null filter at java.io.ObjectInputStream.setInternalObjectInputFilter(ObjectInputStream.java:1316) at java.io.ObjectInputStream.access$000(ObjectInputStream.java:218) at java.io.ObjectInputStream$1.setObjectInputFilter(ObjectInputStream.java:290) at sun.misc.ObjectInputFilter$Config.setObjectInputFilter(ObjectInputFilter.java:392) at com.rapidminer.repository.resource.ResourceIOObjectEntry.lambda$readMetaDataObject$0(ResourceIOObjectEntry.java:166) at java.security.AccessController.doPrivileged(Native Method) at com.rapidminer.repository.resource.ResourceIOObjectEntry.readMetaDataObject(ResourceIOObjectEntry.java:165) at com.rapidminer.repository.resource.ResourceIOObjectEntry.retrieveMetaData(ResourceIOObjectEntry.java:97) at com.rapidminer.operator.io.RepositorySource$1.run(RepositorySource.java:133) at com.rapidminer.gui.tools.ProgressThread$3.run(ProgressThread.java:586) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)


  • Options
    bjorn1bjorn1 Member Posts: 2 Newbie
    I'm using rapidminer 9.10.001 by the way.
  • Options
    c_cheec_chee Member Posts: 18 Maven
    I'm having exactly the same error after doing Tutorial - Prepare Data - Writing Data. I suspect it has something to do with the Store operator

    Please help.   RM v9.10.011

  • Options
    c_cheec_chee Member Posts: 18 Maven
    I think this is an interface glitch that got saved onto the configuration. 

    I tried many things, including:
    1. Since my original installation was NOT Windows type installation, rather it was just unzipped to a directory, I easily deleted the whole program directory and unzipped from the same zip package again. It did not solve the problem.
    2. C:\Users\xxx\.RapidMiner    - deleted everything here. I'm assuming it is all the user related usage settings here. Did not help.
    3. C:\Users\xxx\AppData\LocalLow\Sun\Java\Deployment\cache - This is the main Java area. Deleted everything here. Still did not work.
    4. Did a combination of the above and shutdown / restart. Did not work.

    The error occurred, even with a new canvas, simply drag the Titanic or Iris or perhaps any others in the sample data folder onto the main canvas then the error appears.

    Where would the configuration be affected so deeply, that none of the above steps work. Note the Rapid Miner program files were all deleted and replaced, its user directory are all deleted, even the Java file cache deleted. Where (which file) is the error being triggered?

    WORKING - This is not a solution at all. But I had to remove everything again, and install using the Windows installation method for Rapid Miner. After this it worked.

Sign In or Register to comment.