Options

Right import format for columns

Ellie98Ellie98 Member Posts: 27 Contributor II
edited February 2022 in Help

Hi,

I’m trying to import StudyHour Data inside Rapidminer, which shows the number of hours someone studied a day.

The issue is that it converts into time as what time it is (pm/am) but I’m trying to get hours as the amount of time passed while studying. Not the actual time.

I used the type “hh:mm” in excel as you can see in the picture. I thought that’s the right type but it turns into am/pm hours.

What do I have to do to get it as it is shown in Excel? Do I have to change the type in Excel or do I have to change something in Rapidminer?

Thanks in advance,

Ellie

Best Answer

  • Options
    ceaperezceaperez Member Posts: 541 Unicorn
    Solution Accepted
    Hi @Ellie98

    If you need to work with the total number of minutes studied, you can use the results of the current import and then use the Date to Numerical operator.
    In the operator, if you select the attribute and select minutes as the time unit and day in the "minute relative to" option, the output will be the total minutes relative to midnight.
    for example, the value 2:50 AM CET will be 170 minutes.

    I hope this can help you.

    Best.

    Cesar

Answers

  • Options
    Ellie98Ellie98 Member Posts: 27 Contributor II
    Hi @ceaperez,

    It worked, thank you so much! 

    I have one more question though. Am I able to turn all selected attributes at once into a numerical value without doing all one by one? I tried putting it into the operator "Select Attributes" but it didn't work. 

    Sincerely, 
    Ellie
  • Options
    ceaperezceaperez Member Posts: 541 Unicorn
    Hi @Ellie98

    Please find attached a sample process for that. 


    Cheers, 

    Cesar
Sign In or Register to comment.