MacOS Ventura 'Damaged or incomplete' error message.

drolesdroles Member Posts: 3 Newbie
Hi folks,
I've downloaded 'rapidminer-studio-osx-9.10.13' to my Macbook Pro with OS Ventura 13.0.1 but when I try to open the application I get an error message saying the application can't be opened because it's 'damaged or incomplete'.
I've tried multiple times to download and install but I still get the same error message.

Any ideas?



  • jwpfaujwpfau Employee, Member Posts: 264 RM Engineering

    thank you for your report, after the start failed with the error message, do you see any additional information on the Apple → System Preferences → Security & Privacy window?

    You might have to scroll down quite a lot in Ventura until you reach the Security section:


    Allow applications downloaded from 
    ⚪ App Store
    🔘 App Store and identified developers

    Is there any mention of RapidMiner Studio below this and if yes can you share the reason why Gatekeeper blocked the execution?

  • drolesdroles Member Posts: 3 Newbie
    Thanks Jonas,
    I had a look but couldn't see any further information. I decided to go down the path of running parallels and install/run that way which appears to have worked so far!
    I'll update when I get RapidMiner working fully.

  • abhamit533abhamit533 Member Posts: 1 Learner I
    edited June 16
    32-bit macOS apps won't run on macOS Catalina or Big Sur.
    Apps that virtualized x86 virtual machines and don't use an emulator (such as qemu) don't work on Apple Silicon systems.For both of these, see if you can solve your actual problems in a different way.(Also to my knowledge the M1X isn't out yet??)Spotiflyer
  • jwpfaujwpfau Employee, Member Posts: 264 RM Engineering
    edited June 14

    i wouldn't advise doing it, but you can always just remove the Gatekeeper quarantine flag with 
    xattr -d "Path to the .app"
    Better would be to find out what causes this behavior,

    - From where was the app downloaded?
    - Which browser was used?
    - Is there a chance that Apple server weren't reachable the first time the app was installed?
      - Either by beeing disconnected from the internet or behind a restrictive firewall 

  • drolesdroles Member Posts: 3 Newbie
    • abhamit533 - your comments are a bit beyond my level of knowledge sorry... although I'm running Ventura.
    • App was downloaded using the link from the course files/notes.
    • Browser is Firefox 114.0.1 (64bit)
    • I didn't get any errors suggesting the Apple server wasn't available - restrictive firewall could be the issue as Bitdefender in use.

    Unsure what the problem was however RapidMiner is now running successfully using Parallels. I'm not much of a software/IT guy unfortunately and I'm loath to upset the IT folks by modifying the gatekeeper flag(?)...

    Thank you all!
  • jwpfaujwpfau Employee, Member Posts: 264 RM Engineering
    edited June 14

    Glad to hear that it runs in parallels and thank you for the further information.

    Did your professor/tutor shared the .app or the .dmg? 
    Only the.dmg has the notarization stapled onto it, if you only get the .app this also could also explain this issue.

  • SRASRA Member Posts: 1 Learner I
    I am also having the above problem on Mac OS Ventura 13.3.1 on M1 Mac
Sign In or Register to comment.