Options

Process failed, why?

NatKesRuuNatKesRuu Member Posts: 2 Newbie
Hi,
When I try to run a simple process (you know the introduction: Add the Titanic data as input and connect the retrive box output to the result with a line, then pressing Run) I get a report saying this:

  • Exception: java.lang.IllegalArgumentException
  • Message: null
  • Stack trace:
  • java.base/java.util.concurrent.ForkJoinPool.(Unknown Source)
  • java.base/java.util.concurrent.ForkJoinPool.(Unknown Source)
  • com.rapidminer.studio.concurrency.internal.LazyPool$Instance.getForkJoinPool(LazyPool.java:177)
  • com.rapidminer.studio.concurrency.internal.AbstractConcurrencyContext.getForkJoinPool(AbstractConcurrencyContext.java:218)
  • java.base/java.security.AccessController.doPrivileged(Native Method)
  • com.rapidminer.studio.concurrency.internal.AbstractConcurrencyContext.internalCall(AbstractConcurrencyContext.java:253)
  • com.rapidminer.studio.concurrency.internal.AbstractConcurrencyContext.call(AbstractConcurrencyContext.java:122)
  • com.rapidminer.studio.concurrency.internal.StudioConcurrencyContext.call(StudioConcurrencyContext.java:33)
  • com.rapidminer.Process.executeRootInPool(Process.java:1448)
  • com.rapidminer.Process.execute(Process.java:1412)
  • com.rapidminer.Process.run(Process.java:1382)
  • com.rapidminer.Process.run(Process.java:1268)
  • com.rapidminer.Process.run(Process.java:1221)
  • com.rapidminer.Process.run(Process.java:1216)
  • com.rapidminer.Process.run(Process.java:1206)
  • com.rapidminer.gui.ProcessThread.run(ProcessThread.java:64)

Why did the process failed? 
I totally new to this program, just downloaded Rapid Miner Studio today and noticed that my license is "uninitialized". 


Answers

  • Options
    MartinLiebigMartinLiebig Administrator, Moderator, Employee, RapidMiner Certified Analyst, RapidMiner Certified Expert, University Professor Posts: 3,507 RM Data Scientist
    Hi,
    this looks odd. Even if you did something wrong you should receive a proper error message.

    Can you share the process itself?

    Best,
    Martin
    - Sr. Director Data Solutions, Altair RapidMiner -
    Dortmund, Germany
  • Options
    NatKesRuuNatKesRuu Member Posts: 2 Newbie
    Hi, 

    Problem solved. It looks like it was my license that wasn't initialized. When I logged into RapidMiner later and retried to run the process, everything worked fine. I don't know why, but it seems like there was an delay between the registration and when the license started to work. 

    Thank you anyways for your help.

    Best regards,
    Natalie
Sign In or Register to comment.